Project

General

Profile

Emulator Issues #8742

4.0-6953 won't compile (Linux)

Added by guitaristocrat3 over 4 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong in few words.

Latest dolphin won't compile, it throws evdev errors whenever I try.

Here's the full message on attempting to compile:

Already up-to-date.
x86_64
ALSA found, enabling ALSA sound backend
ao found, enabling ao sound backend
bluez found, enabling bluetooth support
PulseAudio found, enabling PulseAudio sound backend
OpenAL found, enabling OpenAL sound backend
X11 support enabled
Xrandr found
libav/ffmpeg found, enabling AVI frame dumps
PortAudio not found, disabling mic support
-- Could NOT find libevdev (missing: LIBEVDEV_LIBRARY LIBEVDEV_INCLUDE_DIR)
CMake Error at CMakeLists.txt:540 (message):
Couldn't find libevdev and/or libudev. Can't build evdev controller
backend.

Disable ENABLE_EVDEV if you wish to build without controller support

-- Configuring incomplete, errors occurred!
See also "/home/xerxes/Documents/scripts projects/dolphin-emu/build/CMakeFiles/CMakeOutput.log".
See also "/home/xerxes/Documents/scripts projects/dolphin-emu/build/CMakeFiles/CMakeError.log".
x86_64
ALSA found, enabling ALSA sound backend
ao found, enabling ao sound backend
bluez found, enabling bluetooth support
PulseAudio found, enabling PulseAudio sound backend
OpenAL found, enabling OpenAL sound backend
X11 support enabled
Xrandr found
libav/ffmpeg found, enabling AVI frame dumps
PortAudio not found, disabling mic support
-- Could NOT find libevdev (missing: LIBEVDEV_LIBRARY LIBEVDEV_INCLUDE_DIR)
CMake Error at CMakeLists.txt:540 (message):
Couldn't find libevdev and/or libudev. Can't build evdev controller
backend.

Disable ENABLE_EVDEV if you wish to build without controller support

-- Configuring incomplete, errors occurred!
See also "/DOLPHIN DIRECTORY/build/CMakeFiles/CMakeOutput.log".
See also "/DOLPHIN DIRECTORY/build/CMakeFiles/CMakeError.log".
Makefile:772: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1
x86_64
ALSA found, enabling ALSA sound backend
ao found, enabling ao sound backend
bluez found, enabling bluetooth support
PulseAudio found, enabling PulseAudio sound backend
OpenAL found, enabling OpenAL sound backend
X11 support enabled
Xrandr found
libav/ffmpeg found, enabling AVI frame dumps
PortAudio not found, disabling mic support
-- Could NOT find libevdev (missing: LIBEVDEV_LIBRARY LIBEVDEV_INCLUDE_DIR)
CMake Error at CMakeLists.txt:540 (message):
Couldn't find libevdev and/or libudev. Can't build evdev controller
backend.

Disable ENABLE_EVDEV if you wish to build without controller support

-- Configuring incomplete, errors occurred!
See also "/DOLPHIN DIRECTORY/build/CMakeFiles/CMakeOutput.log".
See also "/DOLPHIN DIRECTORY/build/CMakeFiles/CMakeError.log".
Makefile:772: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1

What did you expect to happen instead?|

For Dolphin to compile properly using the same compilation commands I've used for over 2000 revisions.

What steps will reproduce the problem?
1.Try to compile
2.See errors
3.Cry

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0-6953

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

4.0-6930

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Linux Ubuntu 14.10
Intel Core i3-3220 @ 3.3GHz
NVIDIA GeForce GTX 650

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

The contents of the log files it points to are very long, I'll pastebin them and post a link if it's needed though.

History

#1 Updated by degasus over 4 years ago

  • Status changed from New to Invalid

Read the error message.

You'll need libudev-dev and libevdev-dev for controller support. You may also clear the cmake option ENABLE_EVDEV to disable controller support at all.

#2 Updated by guitaristocrat3 over 4 years ago

It would've been nice if the fact that there was a new dependency was actually written somewhere. I assumed since I was compiling with the same script I've used since 4.0-4366 that there was a problem with the cmake.

Also available in: Atom PDF