Project

General

Profile

Emulator Issues #8762

Need for Speed the Run rear lights glitch

Added by 30zaozabot almost 4 years ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Need for Speed The Run

Game ID?
SNVE69

What's the problem? Describe what went wrong in few words.
Red light trail emitted by rear lights appears and disappears while driving

What did you expect to happen instead?
Red light trail should always be on and move accordingly to the car movements

What steps will reproduce the problem?
1. Start any race in the game
2. While driving Red light trail emitted by rear lights appears and disappears

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0 6957
4.0
3.5-0

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1, 8Gb Ram, Intel Core i5-3470, Nvidia Geforce GTX 760

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Yes. Here's video showing how rear light should look https://youtu.be/-ew6gQKIFCE?t=66
And here's how they look in Dolphin https://youtu.be/73rhLzLYWgw?t=206

History

#1 Updated by PEmu almost 4 years ago

This seems to have been posted on the wiki already https://wiki.dolphin-emu.org/index.php?title=Need_for_Speed%3A_The_Run#Rear_Lights_Trail_Glitch but I don't see any existing issue reports for the problem.

#2 Updated by 30zaozabot almost 4 years ago

Yeah, i posted it on wiki. Added issue link

#3 Updated by pauldacheez almost 4 years ago

One of the videos on the wiki page shows tail light trails appearing fine in Dolphin... on D3D9. :\

#4 Updated by 30zaozabot almost 4 years ago

yes, but i searched through comments and description but couldn't find dolphin version or specs. i've tested the game again on versions that should work accordingly to wiki entries, but 3.0-204, 3.0-547 and 3.5 had the same glitch. d3d9, d3d11 and ogl didn't make any difference

#5 Updated by 30zaozabot almost 4 years ago

as user Kolano added to wiki page, this glitch should not occure on 4.0-146 and prior versions with d39d, but i just tested it but issue is still there.

#6 Updated by JMC4789 over 3 years ago

Other people aren't running into the issue though, so, I wonder what's going on.

#7 Updated by 30zaozabot over 3 years ago

What dolphin versions does those "other people" use. Most of the youtube videos featuring NFS The Run on Dolphin have this glitch

#8 Updated by JMC4789 over 3 years ago

I think I bought this game in a binge earlier this week. I'll test it out if so!

#9 Updated by JMC4789 over 1 year ago

  • Assignee set to JMC4789

:( Why didn't I test this

#10 Updated by JMC4789 over 1 year ago

  • Status changed from New to Fixed

Things appear to be working correctly in latest master.

Also available in: Atom PDF