Project

General

Profile

Emulator Issues #8763

Wii Play Motion : real wiimote problems

Added by 30zaozabot over 4 years ago. Updated over 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Controls
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name? Wii Play: Motion

Game ID? SC8E01

What's the problem? Describe what went wrong in few words.
1) Wiimote cursor freezes in main menu, the only solution is to disconnect and connect it again. But it can freeze again in a few seconds
2) While trying to play multiplayer with two wiimotes, game shows a message "Please remove the external extension controller from the wii remote". After removing motion plus from wiimotes, controllers shows as "ready" but then message shows up "motion plus is not connected" and after connecting it again - message does not dissappear and it all starts again with "Please remove the external extension controller from the wii remote".
Connecting and disconnecting nunchuck does not help.

What did you expect to happen instead?
1) Wii cursor should not freeze during the game
2) Miltiple wiimotes should work fine without any issues

What steps will reproduce the problem?
1. Star menu shows up with "press A and B to start" and then cursor freezes.
2. In any game mode with multiplayer, select two players
3. When trying to start the game message shows up "Please remove the external extension controller from the wii remote".

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0 6970
3.5 144

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Yes. 3.5 144 doesn't have these issues

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1, 8Gb Ram, Intel Core i5-3470, Nvidia Geforce GTX 760

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Message screenshot http://imgur.com/5OXur4g

History

#1 Updated by MayImilae over 4 years ago

  • Status changed from New to Questionable

Which bluetooth stack are you using?

#2 Updated by MayImilae over 4 years ago

  • Category set to controls

#3 Updated by 30zaozabot over 4 years ago

Toshiba Bluetooth Stack. Works perfectly in other games.

#4 Updated by 30zaozabot over 4 years ago

If someone can tell me which log options to turn on that can help to isolate cause of the problem, i would gladly participate in fixing this issue

#5 Updated by JMC4789 over 4 years ago

It's likely a sysconf issue; dumping a real NAND from a Wii will fix it.

#6 Updated by 30zaozabot over 4 years ago

Tried it, no effect.

#7 Updated by fakebalsalmalberto over 4 years ago

I'm getting the same message. I'm using a single real Wii-mote with Mayflash Dolphin-bar and Dolphin v4.0.7182.

#8 Updated by JMC4789 about 4 years ago

  • Status changed from Questionable to Accepted

Damn.

#9 Updated by JMC4789 over 3 years ago

  • Status changed from Accepted to Invalid

I can't reproduce the freezing Wiimote. I can reproduce the Wiimote thinking there is an unknown device attached, but, we have a separate issue for that.

Played through the first four minigames.

Also available in: Atom PDF