Project

General

Profile

Actions

Emulator Issues #8771

closed

Guitar Hero Warriors of Rock Wifi Not working in latest builds

Added by Anonymous over 7 years ago.

Status:
Fixed
Priority:
High
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Guitar Hero: Warriors of Rock

Game ID?

SXIE52

What's the problem? Describe what went wrong in few words.

The problem is that recent builds don't let the game online. Normally when the game boots it will say "Connected to Nintendo Wi-Fi" and shortly after say "Connected to Game Servers".

What did you expect to happen instead?

After going through the intro movie, there should be a message that says "Connected to Nintendo Wi-Fi" and shortly after, a message that says "Connected to Game Servers"

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]

  1. To reproduce this, start up Warriors of Rock on any recent Dolphin build and it will not show any message about connecting to Wifi. After 30 seconds or so, it will say that the game is not connected to Nintendo Wifi.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

I have tested Dolphin 6502, 6454, 6531, 6512, 6988, 6260, and 6448.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

Yes, any build prior to 6512 works just fine. The merge regarding a rdimentary version of Wii IPC determinism.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Windows 7 x64
Intel Core i5 2500 3.30GHz
Nvidia GeForce 560 Ti
16 GB Dual-Channel DDR3

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Connected to Wifi message (which should appear instantly): http://i.imgur.com/nJaT2Jd.png

What happens on newer builds: http://i.imgur.com/kwga3pd.png

Actions #2

Updated by JMC4789 over 7 years ago

  • Status changed from New to Accepted
  • Regression set to Yes
  • Milestone set to Current
  • Priority set to High
Actions #3

Updated by comexk over 7 years ago

  • Status changed from Accepted to Fix pending
Actions #4

Updated by JMC4789 over 7 years ago

  • Status changed from Fix pending to Fixed
Actions #5

Updated by JosJuice over 7 years ago

  • Status changed from Fixed to Fix pending

Not in stable.

Actions #7

Updated by Anonymous over 7 years ago

Sorry for late response, but got a chance to test the build out. Works fine in the latest build, thanks for the fix!

Actions #8

Updated by Armada over 7 years ago

  • Status changed from Fix pending to Fixed
Actions

Also available in: Atom PDF