Project

General

Profile

Actions

Emulator Issues #8775

closed

Wii System Memory is limited

Added by Stevoisiak over 7 years ago. Updated over 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Any

Game ID?
N/A

What's the problem? Describe what went wrong in few words.
I managed to run out of Wii System Memory in Dolphin and am unable to create new save games.

What did you expect to happen instead?
To have my save data be limited only by my hard drive space.

What steps will reproduce the problem?

  1. Fill up the Wii's memory by installing WiiWare/VC games to the Wii Menu
  2. Once memory is full, try to make a new save file in any Wii game
  3. Check Wii's Data Management settings to see 0 available blocks

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-6988
4.0-6732
4.0-430
3.5-2411
3.0-749

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1, 931 GB Hard Drive

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
I am using NAND dumped from a real Wii, and am on System Menu 513E (4.3U)
I am unable to see if deleting game channels frees up space, as it crashes Dolphin. (Issue #8666)
http://imgur.com/a/T7QNY

Actions #1

Updated by skidau over 7 years ago

  • Issue type changed from Bug to Feature request

This won't be possible because the Wii NAND file system maintains an index of finite entries. Out of interest, what is the size of your Wii folder in Dolphin?

Actions #2

Updated by Stevoisiak over 7 years ago

2.8 GB, so this isn't an issue most users will be running into.

Actions #3

Updated by Stevoisiak over 7 years ago

Disregard my comment about installing WADS. For some reason, after clearing some space, I am able to install more WADs to the menu without using up any more blocks in memory. Deleting them also seems to have no effect.

I'll need to do more testing, but I have a suspicion that only Wii save games actually count towards the "used blocks", while installed channels are ignored.

Actions #4

Updated by Stevoisiak over 7 years ago

After close examination, it seems that, for the most part, the only things that contribute to blocks used are Disc-based saves [00010000/00010004], and DLC [00010005]. Deleting WiiWare [00010001] only saved 3 blocks, despite having nearly 300MB of data.

You can seemingly store an infinite amount of WiiWare games and save files without affecting the blocks remaining count.

Actions #5

Updated by JMC4789 over 6 years ago

  • Status changed from New to Invalid

I ran into this issue as well. I'm now running 3 Nands at this point.

I don't think it can be fixed without very nasty hacks so I'm closing this issue as much as it pains me.

Actions

Also available in: Atom PDF