Project

General

Profile

Emulator Issues #8778

Tom and Jerry in War of the Whiskers: UI completely missing

Added by blargland about 5 years ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Tom and Jerry in War of the Whiskers

Game ID?
GTJE5L

What's the problem? Describe what went wrong in few words.
The game's UI, including menus and health bars, is totally missing - bar the level select images and the game's logo that appears prior to the main menu.

What did you expect to happen instead?
The game to have a visible main menu.

What steps will reproduce the problem?
1. Start the game. There will be a black screen; wait until Tom and Jerry appear, followed by the War of the Whiskers logotype.
2. Press Start at this screen; you will be presented with another black screen. (this is where the main menu should be)
3. Press A a few times until the screen shows the word PAWS, with a beach background. Press A again, and the actual game will start - at the top right and left-hand corners, there should be a character portrait, a health bar and a "Berserk" bar beneath that. None of these are present.
4. Press Start to pause the game. The pause menu does not appear.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-6990
4.0.2
4.0-1

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
The issues outlined here are not present in 4.0-1, but there are other issues; the game performs poorly and crashes at the end of each fight. These are not present under 4.0-6990.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
AMD Phenom II x6 1050T processor clocked at 3.3GHz
AMD Radeon HD 7870 GPU
8GB RAM
Windows 7 Professional x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Screenshot of the game: https://i.imgur.com/c2NCgow.png
Screenshot showing health bars: http://www.frictionlessinsight.com/revpics/TJWW/TJWW_B.jpg (how the game should look)
Log: http://pastebin.com/RDyyGNUP (in which I started the game, selected Challenge mode, and played through a single fight. At the end of the fight, I paused the game.)
The configs are all defaults, except for "Scaled EFB Copy", which is unchecked.

History

#1 Updated by JMC4789 about 5 years ago

Have you tried unchecking fast depth?

#2 Updated by blargland about 5 years ago

I've just tried it now. No effect.

#3 Updated by Stevoisiak about 5 years ago

  • Status changed from New to Accepted

Can confirm that the main menu only appears when using Software Renderer

#4 Updated by Stevoisiak about 5 years ago

It last worked in 4.0-3746 in Direct3D, and 4.0-160 in OpenGL

#5 Updated by PEmu about 5 years ago

Should this be marked as a regression?

#6 Updated by kolano about 3 years ago

We have a wiki test report that this is resolved in 5.0-4668, though I'd imagine it occurred well before then.

#7 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Fixed

Everything is working normally in master, marking as fixed.

Also available in: Atom PDF