Project

General

Profile

Emulator Issues #8779

"Failed to link shaders" in Pokemon XD

Added by kanepyork over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name? Pokemon XD
Game ID? GXXE01

What's the problem? Describe what went wrong in few words.

When you go to load a saved game, the following error popup occurs:

> Failed to link shaders: /home/kane/.dolphin-emu/Dump/bad_p_0.txt
Debug info (Intel Open Source Technology Center, Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) , 3.3 (Core Profile) Mesa 10.5.1):
error: definitions of interface block `VertexData' do not match

Dismissing the error allows the game to continue.

A screenshot is attached, as is the mentioned file.

What did you expect to happen instead?

Shader compilation should not fail.

What steps will reproduce the problem?
Attempt to load a saved game on this system. Running the emulator twice causes the error to happen again, with the dumped filename incrementing by 1.

Which versions of Dolphin did you test on?

Dolphin 4.0-6800, compiled locally

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

Did not attempt

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Linux/Xubuntu 15.04 with Intel Graphics Stack Updates
CPU: Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz
GPU: Broadwell Integrated with nVidia Optimus discrete card (not currently in use, integrated was more than enough to run the intros)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Mentioned file: http://pastie.org/10287516
Screenshot of error: http://i.imgur.com/DjfTu5u.png


Related issues

Is duplicate of Emulator - Emulator Issues #8676: AMD Open source drivers, shader compilation problem.Fixed

History

#1 Updated by kanepyork over 4 years ago

First guess - the "centroid" keyword is missing here - http://pastie.org/10287516#252-257

#2 Updated by kanepyork over 4 years ago

Just compiled 4.0-6997-gb30ae1b and the issue is gone - the emulator simply stutters for a bit there.

#3 Updated by JosJuice over 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF