Project

General

Profile

Emulator Issues #8830

Sonic Riders story mode load hang (thread loop lock)

Added by Paul.Hancock.17041993 about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name? Sonic Riders

Game ID? GXEE8P

What's the problem?

While playing the story mode, up to the 4th race of the hero side, the emulation will completely hard-lock on the loading screen a few seconds after selecting the story from the menu.
Dolphin must be forced-terminated via task manager as you cant stop the emulation at all even though the windows are still responsive.

What did you expect to happen instead?

The game should be able to load correctly obviously, but more importantly Dolphin should be able to recover and fully terminate the emulation instead of it being stuck.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]

  1. load up the game, save/load to a memory card etc,
  2. proceed to game start > story mode > heros
  3. the first 3 races will have to be finished if its from scratch, the bug occurs when going into the 4th

Which versions of Dolphin did you test on?

4.0-7138, a prior version would have a complete crash instead of an emulation lock, though I don't remember what build number

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

unknown/no

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

OS: win 8.1 pro x64
Drivers: catalyst 15.7
CPU: FX-8150 (stock)
GPU: R9 290X (stock, custom cooled)
RAM: 16GB DDR3 @ 1866MHz
Dolphin installed on the C drive, a SSD RAID0
game ROM located on the D drive, a HDD RAID1

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

log, or what I could obtain;
http://pastebin.com/sUm09Epz
note that the bug also causes the logging system to 'implode on itself' so to speak, log-to-file is completely non-functional and to obtain a usable log involves having log-to-console/window enabled and then disabled when the error occurs, otherwise it just infinitely grows

The 'export all wii saves' doesn't seem to be working for me to supply a wii save file to skip the first 3 races... or at least it doesn't give an option of where to export to like it ideally should and I haven't found anything in the documents > dolphin emulator folder...


Related issues

Is duplicate of Emulator - Emulator Issues #8725: Sonic Riders, Unknown InstructionFixed

History

#1 Updated by JosJuice about 5 years ago

  • Status changed from New to Duplicate

Sounds like issue 8725, even though the description of what happens afterwards is a bit different.

#2 Updated by Paul.Hancock.17041993 about 5 years ago

I think the main problem though is the emulator just keeps trying to perform the operation and breaks all of dolphin's functionality in the process, instead of just aborting. Or at least it should be able to fully terminate the emulation when stuck in such a loop. The particular unknown instruction is a secondary issue and is mostly a trigger for this loop-lock bug.

Also available in: Atom PDF