Project

General

Profile

Emulator Issues #8847

Paper Mario 2/TTYD - game crashes after obtaining a stone key

Added by Treflakune almost 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Paper Mario 2 / The Thousand Year Door

Game ID?
G8ME01

What's the problem? Describe what went wrong in few words.
every time I enter the door from attached photo, I get an unknown pointer issue. Specific issue also attached.

What did you expect to happen instead?
to go through the door and get to the other stone key.

What steps will reproduce the problem?

  1. winning the questionnaire in petalburg woods
  2. gaining one stone key
  3. trying to get to the other hallway containing the second stone key

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.070
Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
no

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8, ?? (its an ASUS laptop I bought brand new a year ago.)

Is there any other relevant information?
I attached two screenshots

History

#1 Updated by JMC4789 almost 6 years ago

Provide a savefile as close to the crash as possible. Not a savestate, but a save file, .gci file from the memory card or memory card folder if you're using that feature.

Also, try using single core; unknown pointers can happen on GPU desyncs with bounding box effects.

#2 Updated by MayImilae almost 6 years ago

And please provide your full specs and dolphin version. If you don't know what is inside your laptop exactly, please provide the make and model number!

#3 Updated by Treflakune almost 6 years ago

Using 4.0.070, here's the .gci, and my specs are
Microsoft 8.1
nvidia geforce gtx 745
i7 dual Intel core
ASUS NotebookSKU

thanks for helping out!

#4 Updated by shellashock almost 6 years ago

Could you try using the latest master build (4.0-7209 at the time of writing) and see if that fixes it? Single or Dual Core alike, I am not getting a pointer crash with latest master after getting one stone key and going through the door to get the second one.

Specs are:

Windows 7 Pro x64
AMD Athlon II x2 B24
ASUS Radeon R7 240

#5 Updated by Treflakune almost 6 years ago

I dunno what that update had but it works now! Thanks hellokitty

#6 Updated by shellashock almost 6 years ago

No problem. This can be marked invalid then due to out of date version.

#7 Updated by JMC4789 over 5 years ago

  • Status changed from New to Invalid

There is no reason upgrading should have fixed it, but okay.

Also available in: Atom PDF