Project

General

Profile

Emulator Issues #8857

[HLE] Bratz: Rock Angelz Multiple SFX Issues

Added by adiffin502 almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Bratz: Rock Angelz

Game ID?
GR6P78

What's the problem? Describe what went wrong in few words.
Multiple sound effects in the game (almost all of them) exhibit a strange "slow-down" effect. This does not occur with LLE audio, and changing back-ends does not produce any improvements. I haven't tested the NTSC version (and given the game, I don't feel like planning on doing so!) This problem isn't limited to just regular HLE and also occurs on NZHLE.

What did you expect to happen instead?
Expected all sounds to sound the same on both HLE and LLE.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Go to the main menu.
2. Scroll down to "Options."
3. After choosing Options, you should immediately notice that the sound effects are distorted, even if you don't know what they normally sound like. They are distorted from the beginning, but the Options menu is the quickest way to hear the distorted sounds.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
About 16 builds, from 4.0-5400 to 4.0-7202 and 4.0-7247 [NZHLE]

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
N/A

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]
HLE: https://drive.google.com/file/d/0B3AFeSVGmg9sQlNzRUY2TU04bms/view?usp=sharing
LLE: https://drive.google.com/file/d/0B3AFeSVGmg9sVzltT01XWTlrRjA/view?usp=sharing


Related issues

Is duplicate of Emulator - Emulator Issues #7322: Slow audio ingame in various gamecube games when using HLE, LLE audio works fine. (48KHz Issue?)Fixed

History

#1 Updated by shellashock almost 6 years ago

This is a known issue and issue 7322 has listed other games affected. AFAIK, this issue of slow HLE is on the backburner for now and has no known fix besides switching to LLE. Thanks for the report!

#2 Updated by delroth almost 6 years ago

  • Status changed from New to Duplicate

It's not a Zelda HLE issue either -- the game does not use Zelda UCode. Closing as duplicate.

Also available in: Atom PDF