Project

General

Profile

Emulator Issues #8864

SSBB Alloc Buffer failed

Added by ryanebola16 over 3 years ago. Updated 6 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Super Smash Bros. Brawl

Game ID?
RSBE01

What's the problem? Describe what went wrong in few words.
I am using a custom Brawlex setup and the game will usually silent freeze after playing 20ish matches while loading a stage. "Alloc Buffer failed" appears in my log, followed by "Open failed" entries. Two examples:
http://i.imgur.com/hECjkTl.png
http://i.imgur.com/s6yEXI5.png

To make sure the problem wasn't my setup, I selected the same characters and stage that caused the Alloc Buffer error upon restarting Dolphin. There was no problem.

Since I do not wish to distribute this custom build yet, is there more useful logging information that I can provide?

What did you expect to happen instead?
No Alloc Buffer failed!

What steps will reproduce the problem?
1. Play 20ish matches (I found the problem occurs quickest when 4 players/CPUs are involved).
2. Observe silent freeze upon loading a stage and "Alloc Buffer failed" messages in the log

Which versions of Dolphin did you test on?
Dolphin 4.0-7207

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No, this problem has probably always been present.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Win 10 Pro x64
Intel Core i7-4702MQ CPU @2.20GHz
GeForce GT 750M

AllocBufferFailed50-1473.txt (1.24 MB) AllocBufferFailed50-1473.txt ryanebola16, 12/15/2016 06:59 AM

History

#1 Updated by ryanebola16 over 3 years ago

I should also mention that the first log was taken with panic handlers disabled. The second log had panic handlers enabled.

#2 Updated by JMC4789 over 3 years ago

Monitor ram usage during this, please. I wonder if there's some weird ram leak going on.

#3 Updated by ryanebola16 over 3 years ago

Perfmon memory log and full dolphin log spanning emulator startup to about 20 seconds post "Alloc Buffer failed":
http://www.mediafire.com/download/qmqq9h36jf8vldl/Alloc+Buffer+failed.zip

#4 Updated by ryanebola16 over 3 years ago

Additionally, stage loading time did slightly increase as gameplay progressed.

#5 Updated by JMC4789 about 3 years ago

I honestly don't know what could cause this. Does Brawl itself have this issue, or only when you load the mods?

#6 Updated by ryanebola16 about 3 years ago

The issue only occurs with the mods.

#7 Updated by JMC4789 about 3 years ago

The high barrier to reproduce this issue is going to make it hard to fix. We're going to have to rely on you to narrow it down in some way for it to get fixed. Here's my suggestions, assuming the alloc buffer isn't enough (honestly, I don't even know what it is, so, my suggestions may just waste your time. I just hate letting the issue sit with nothing said or done.)

Does it only happen on a JIT? I know cached interpreter will be a lot slower, but it should be playable enough to do at least ONE playthrough (20 matches may take a lot longer... but, if it's one run to see if it works or not, it may be worth it.)

I'm sure you've tried various graphics settings, but, it may be worth fussing with them to see if you can affect anything.

Have you tried savestating before the crash? Is it more/less consistent loading from a savestate?

Do you know if the game can freeze on actual Wii?

#8 Updated by ryanebola16 about 3 years ago

Sorry for taking so long to respond.

I have tested the issue with Dolphin 4.0-7958 and still get Alloc Buffer failed. Just to be clear on my settings, I am running Dolphin in debug mode with the following config files (also contains the Alloc Buffer failed log from 4.0-7958 on JIT):
http://www.mediafire.com/download/73tgsqapfo1fdbi/Dolphin+7958+Config.rar

I then changed to cached interpreter and could no longer reproduce the problem.

Side note: JITL fails to properly load my codes from Sd.raw using Gecko OS .dol. Should I make a separate issue for this?

#9 Updated by JMC4789 almost 3 years ago

Cached Interpreter working is a bit confusing to me. That's enough information to keep the issue open, though.

#10 Updated by ryanebola16 almost 3 years ago

Just FYI, I'm still able to reproduce the issue in 4.0-8860 with JIT

#11 Updated by ryanebola16 over 2 years ago

Possibly related to Issue #9602 (SSBB Mod: Missing portrait after playing the game for some time)

#12 Updated by ryanebola16 over 2 years ago

Occurred again with 5.0-424. Since my visual studio setup is still having issues, if someone wants to build the Dynamic BAT PR for me I'd be willing to do some testing with it.

#13 Updated by PEmu about 2 years ago

ryanebola16 wrote:

Occurred again with 5.0-424. Since my visual studio setup is still having issues, if someone wants to build the Dynamic BAT PR for me I'd be willing to do some testing with it.

You can download a build here: https://dl.dolphin-emu.org/prs/pr-1882-dolphin-latest-x64.7z

#14 Updated by ryanebola16 about 2 years ago

Thank you! This problem still occurred in the new Dynamic Bat PR however.

#15 Updated by ryanebola16 almost 2 years ago

I just reproduced the issue in 5.0-1473. Hopefully a pattern will emerge in these Dolphin logs...

#16 Updated by ryanebola16 about 1 year ago

I finally sat down and did no-codes, 300% damage, fast brawl, 4 random characters, random stage for an hour with as little time as possible between matches. I could not reproduce this issue. Since I have only seen it with Brawlex, I think the problem lies with the Brawlex modifications and not Dolphin emulator.

#17 Updated by ryanebola16 6 months ago

Reminder to close as invalid. This is likely due to module conflicts between fighters when using Brawlex.

#18 Updated by JosJuice 6 months ago

  • Status changed from New to Invalid

Also available in: Atom PDF