Project

General

Profile

Emulator Issues #8881

Star Wars - Rogue Squadron II and III - Video Overlaying Backdrop has very visible edges.

Added by kolano over 4 years ago. Updated almost 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-7151

Description

Game Name?
Star Wars - Rogue Squadron III - Rebel Strike

Game ID?
GLRE64

What's the problem? Describe what went wrong in few words.
Fade-out/Fade-in transitions are missing between scenes.

What did you expect to happen instead?
Transitions to occur as on GC/Wii.

What steps will reproduce the problem?
1. Select game slot
2. Start "Revenge of the Empire"
3. Enter X-wing
4. Wait for text scroll
5. After the Death Star explodes the scene should fade out, and then back in to the ship flyby.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-7207

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Unknown

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel i7-960, NVIDIA 580

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
https://wiki.dolphin-emu.org/index.php?title=File:Star_Wars_Rogue_Squadron_III-Video_edges.jpg
https://youtu.be/iRU6XtXd2vo?t=2m12s

History

#1 Updated by JMC4789 over 4 years ago

Can confirm this happens as well.

#2 Updated by ventus11223 over 4 years ago

Happens with me as well, but isn't it well-known that Rogue Leader and Rebel Strike have lots of issues right now since they're still only recently able to be emulated?

#3 Updated by JMC4789 over 4 years ago

It's important regardless.

#4 Updated by phire over 4 years ago

The transitions happen if you use RealXFB.

#5 Updated by kolano over 4 years ago

I had tested that, as I had initially thought the same thing, but it's not true. Just retested to make sure, same issue is seen regardless of XFB setting.

#6 Updated by JMC4789 over 4 years ago

  • Subject changed from Star Wars - Rogue Squadron III Scene Transitions to Star Wars - Rogue Squadron II and III - Video Overlaying Backdrop has very visible edges.

This issue is weirdly worded. Basically, in certain cutscenes they play footage of the movies (like the death star explosion) over their own backdrop of stars.

#7 Updated by nael.masood almost 4 years ago

This bug doesn't actually capture what the issue actually is. What's going on is that on the original hardware, there's a fade to black after the movies play that fades back in to gameplay very quickly. What happens on Dolphin is that this fade to black isn't emulated, so the game awkwardly moves the video over a bit before switching to the gameplay - a transition that is hidden by the fade to black on the original hardware.

The YouTube video in the original report shows what happens with the game on the original hardware. The YT vid I'm about to link show the same scene running on Dolphin, albeit an older version - pay attention to what happens after the video finishes at around the 2:00 mark:
https://www.youtube.com/watch?v=YFzlTM-6AvE

I don't have Rogue Leader to test against newer builds, but I do have a game that has a similar problem - Soulcalibur II makes use of these fade-to-black transitions as well for switching scenes but because Dolphin can't emulate them, the transitions are awkward jump cuts to a new scene instead. I previously filed a bug for Soulcalibur II's lack of fades at Issue:8429, but there hasn't been much movement on that bug there since the switch to the new issue tracker. I can confirm these issues still happen on SCII on build 4.0-9308, and it happens regardless of the XFB setting.

#8 Updated by JMC4789 almost 4 years ago

That's true, Dolphin is missing some kind of fade in a lot of games.

#9 Updated by LtRoyalShrimp almost 4 years ago

From Julian Eggebrecht:

The video is a additive alpha layer over the background. The video itself is mjpeg.

#10 Updated by kolano over 2 years ago

This worsened a bit with Hybrid XFB, as the transitions now render as bright purple. Requires XFB to Texture disabled to render appropriately.

#11 Updated by JMC4789 over 2 years ago

that's not any worse? They rendered bright green before in RS3

#12 Updated by JMC4789 almost 2 years ago

  • Fixed in set to 5.0-7151
  • Status changed from New to Fixed

This is fixed.

Also available in: Atom PDF