Project

General

Profile

Emulator Issues #8935

Star Fox Assault - Crashing in Multiple Stages

Added by cubatilles almost 4 years ago. Updated 3 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-10379

Description

There's an old bug, according to the wiki, with Starfox Assault, named "Fifth Mission Crash", which, as explained on the wiki: "In the fifth mission, when you reach the infected prototype, the game crashes. Using the JitIL recompiler fixes this issue. ". According to the wiki, this fix was already solved since 4.0-971.

But I've discovered, that if you die in that mission after that point (infected prototype), you will continue in next life from close earlier that point, and then, reaching the infected prototype, the game and dolphin will crash. It never happens on first life, only when retrying after one die, and it always happens, afaik.

I've tested the bug on the last revision, 4.0-7636, but it's happening since lotta time ago. It doesn't matter if you use the JITIL recompiler or not, it will always happen.

I'm using the 4.0-7636 revision on Windows 7 x64.


Related issues

Has duplicate Emulator - Emulator Issues #10538: Aparoid Homeworld Has an odd Crash While Texture DumpingDuplicate

History

#1 Updated by MayImilae almost 4 years ago

Please list the Game ID of your copy of Star Fox Asssault and your system specs.

#2 Updated by JosJuice almost 4 years ago

  • Subject changed from Bug on Starfox Assault (GameCube) to Star Fox Assault crashes in fifth mission
  • Operating system N/A added
  • Operating system deleted (Windows)

#3 Updated by cubatilles almost 4 years ago

Hello,

Here's the missing information:

Game ID: GF7E01
OS: Windows 7 x64
I3-3500 @ 3,5GHz
4GB RAM
GPU AMD Radeon R7 240 - 2GB
Dolphin 4.0-7636 w/backend OpenGL Standard settings (the problem happens also with D3D and any settings I've tried so far).

#4 Updated by JMC4789 almost 4 years ago

Could you please get a coredump of the crash in latest master? Basically, if you're in windows, when Dolphin crashes, open up task manager, find Dolphin in the list of processes, right click it, create core dump (it should be something akin to that in all versions of Windows,) and then find that file, compress it and upload it.

Note which build number you were using.

#5 Updated by cubatilles almost 4 years ago

4948

Hi,

The compressed dump file is abut 120MB... I can't upload it here, so I had to upload to a file sharing service where I have an account. The link is valid for 3 months:

https://svtdocsbcn.svtcloud.com/?ShareToken=54332B017BB395DB527694F1304A64AF44632A74

Btw I'm attaching a screenshot of the error message Dolphin says when crashing.

I've done these last tests with latest revision, 7739.

#6 Updated by JMC4789 almost 4 years ago

  • Assignee set to Anonymous

I'm going to ask shuffle2 to look at the coredump if possible.

#7 Updated by Anonymous almost 4 years ago

The crashing stack:

 # Child-SP          RetAddr           Call Site
00 00000000`0bc2e3e8 00000000`77244bc4 user32!NtUserWaitMessage+0xa
01 00000000`0bc2e3f0 00000000`77244edd user32!DialogBox2+0x274
02 00000000`0bc2e480 00000000`77292920 user32!InternalDialogBox+0x135
03 00000000`0bc2e4e0 00000000`77291c15 user32!SoftModalMessageBox+0x9b4
04 00000000`0bc2e610 00000000`7729146b user32!MessageBoxWorker+0x31d
05 00000000`0bc2e7d0 00000000`77291362 user32!MessageBoxTimeoutW+0xb3
06 00000000`0bc2e8a0 00000000`00700243 user32!MessageBoxW+0x4e
07 00000000`0bc2e8e0 00000000`006fea1e Dolphin!wxMessageDialog::ShowMessageBox+0x7e3 [c:\buildbot\slaves\dolphin\release-win-x64\build\externals\wxwidgets3\src\msw\msgdlg.cpp @ 589]
08 00000000`0bc2eaa0 00000000`00650eb1 Dolphin!wxMessageDialog::ShowModal+0x2e [c:\buildbot\slaves\dolphin\release-win-x64\build\externals\wxwidgets3\src\msw\msgdlg.cpp @ 628]
09 00000000`0bc2eae0 00000000`0054e680 Dolphin!wxMessageBox+0x71 [c:\buildbot\slaves\dolphin\release-win-x64\build\externals\wxwidgets3\src\common\utilscmn.cpp @ 1368]
0a 00000000`0bc2eff0 00000000`0087954c Dolphin!wxMsgAlert+0xf0 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\dolphinwx\main.cpp @ 387]
0b 00000000`0bc2f0e0 00000000`0090b859 Dolphin!MsgAlert+0x4fc [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\common\msghandler.cpp @ 84]
0c 00000000`0bc2f9e0 00000000`008f0809 Dolphin!Memory::GetPointer+0x89 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\core\hw\memmap.cpp @ 316]
0d 00000000`0bc2fa20 00000000`008f295b Dolphin!VertexLoaderManager::UpdateVertexArrayPointers+0x49 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\vertexloadermanager.cpp @ 75]
0e 00000000`0bc2fa50 00000000`008f02ea Dolphin!VertexLoaderManager::RefreshLoader+0x3eb [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\vertexloadermanager.cpp @ 170]
0f 00000000`0bc2fb20 00000000`008f65aa Dolphin!VertexLoaderManager::RunVertices+0x4a [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\vertexloadermanager.cpp @ 181]
10 00000000`0bc2fb90 00000000`008f6793 Dolphin!OpcodeDecoder_Run<0>+0x26a [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\opcodedecoding.cpp @ 284]
11 00000000`0bc2fc10 00000000`008f6510 Dolphin!InterpretDisplayList+0x63 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\opcodedecoding.cpp @ 56]
12 00000000`0bc2fc50 00000000`008ee804 Dolphin!OpcodeDecoder_Run<0>+0x1d0 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\opcodedecoding.cpp @ 233]
13 00000000`0bc2fcd0 00000000`008ee359 Dolphin!<lambda_e27b0212efe93e7c3321b48cb66db9c2>::operator()+0x1d4 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\fifo.cpp @ 337]
14 00000000`0bc2fd60 00000000`008ee035 Dolphin!Common::BlockingLoop::Run<<lambda_e27b0212efe93e7c3321b48cb66db9c2> >+0x49 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\common\blockingloop.h @ 106]
15 00000000`0bc2fdc0 00000000`0090a10a Dolphin!RunGpuLoop+0x35 [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\videocommon\fifo.cpp @ 374]
16 00000000`0bc2fdf0 00000000`008e9951 Dolphin!Core::EmuThread+0x4aa [c:\buildbot\slaves\dolphin\release-win-x64\build\source\core\core\core.cpp @ 522]
17 (Inline Function) --------`-------- Dolphin!std::_Invoker_functor::_Call+0x2 [c:\program files (x86)\microsoft visual studio 14.0\vc\include\type_traits @ 1408]
18 (Inline Function) --------`-------- Dolphin!std::invoke+0x2 [c:\program files (x86)\microsoft visual studio 14.0\vc\include\type_traits @ 1476]
19 (Inline Function) --------`-------- Dolphin!std::_LaunchPad<std::unique_ptr<std::tuple<void (__cdecl*)(void)>,std::default_delete<std::tuple<void (__cdecl*)(void)> > > >::_Execute+0x2 [c:\program files (x86)\microsoft visual studio 14.0\vc\include\thr\xthread @ 238]
1a 00000000`0bc2fec0 00000000`008a9aa9 Dolphin!std::_LaunchPad<std::unique_ptr<std::tuple<void (__cdecl*)(void)>,std::default_delete<std::tuple<void (__cdecl*)(void)> > > >::_Run+0x71 [c:\program files (x86)\microsoft visual studio 14.0\vc\include\thr\xthread @ 245]
1b 00000000`0bc2ff00 000007fe`f394173d Dolphin!std::_Pad::_Call_func+0x9 [c:\program files (x86)\microsoft visual studio 14.0\vc\include\thr\xthread @ 208]
1c 00000000`0bc2ff30 00000000`76f0652d ucrtbase!thread_start<unsigned int (__cdecl*)(void * __ptr64)>+0x5d
1d 00000000`0bc2ff60 00000000`7785c521 kernel32!BaseThreadInitThunk+0xd
1e 00000000`0bc2ff90 00000000`00000000 ntdll!RtlUserThreadStart+0x1d

Not sure why this is assigned to me.

BTW JMC if you are interested, getting this kind of info out of the dump is pretty easy:

.symfix
.sympath+ http://symbols.dolphin-emu.org
.reload /f
~*kn

Now look for the stack trace that looks like it has a problem. Done!

p.s. if there's an actual crash, not a window popup like this case, you can use !analyze -v and windbg will automatically tell you what went wrong. Easy :)

#8 Updated by Anonymous almost 4 years ago

  • Assignee deleted (Anonymous)

#9 Updated by JMC4789 almost 4 years ago

  • Status changed from New to Accepted
  • Milestone set to Current

Confirmed the crash

#10 Updated by JMC4789 almost 4 years ago

Reproduced on D3D and OpenGL.

#11 Updated by JMC4789 almost 4 years ago

Tested disabling the vertex loader as well, didn't seem to help.

#12 Updated by JMC4789 almost 4 years ago

Sometimes I can get the crash to trigger on my first playthrough of the level (depending on how much I fire my laser) but 100% of the time it seems to happen on the second playthrough of it.

#13 Updated by JMC4789 almost 4 years ago

This has always happened; even before the other crashes were fixed; this is just random at this point. The crash is much, much more likely to happen on Silver/Gold difficulties, on bronze difficulty it only happens after you die like you said.

#14 Updated by JMC4789 over 3 years ago

  • Milestone deleted (Current)

This isn't a regression, so, I think I'm removing it from the list of current issues. Sorry.

#15 Updated by JMC4789 over 3 years ago

This doens't mean the issue isn't valid; it just won't be blocking the 5.0 release.

#16 Updated by JMC4789 almost 3 years ago

Rudimentary and incorrect fix https://github.com/dolphin-emu/dolphin/pull/4266

maybe degasus or phire can come up with the correct fix.

This should fix the crash regardless.

#17 Updated by JMC4789 about 1 year ago

  • Subject changed from Star Fox Assault crashes in fifth mission to Star Fox Assault - Crashing in Multiple Stages

Star Fox Assault - Multiple Crashes seem to come from this.

#18 Updated by JMC4789 about 1 year ago

#19 Updated by JMC4789 3 months ago

  • Fixed in set to 5.0-10379
  • Status changed from Accepted to Fixed

Also available in: Atom PDF