Project

General

Profile

Emulator Issues #8963

SpongeBob SquarePants: Battle for Bikini Bottom - Robo Patrick Boss Battle Unplayable Since 4.0-7538

Added by Disorderly almost 5 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

SpongeBob SquarePants: Battle for Bikini Bottom

Game ID? (right click the game in the game list, properties, info tab)

GQPE78

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

5a8306706f932162ec39a05d4c5a443b

More than likely not the issue.

What's the problem? Describe what went wrong.

At the beginning of the Robo-Patrick boss battle (Industrial Park), SpongeBob will fall through the ground, into the acid and die. The mesh platform that should be there is not. Many objects throughout the game also become partially see-through.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-7528 and before worked.

What are your PC specifications? (CPU, GPU, Operating System, more)

AMD Athlon X4 750K @ 4.1GHz
AMD Radeon HD 7770
Windows 8.1 Pro x64

Is there any other relevant information? Screenshots? Logs? Fifologs?

The issue was first documented here: https://forums.dolphin-emu.org/Thread-gc-spongebob-squarepants-battle-for-bikini-bottom?pid=385644#pid385644


Related issues

Is duplicate of Emulator - Emulator Issues #8930: Wind Waker freezes at Windfall IslandFixed

History

#1 Updated by phire almost 5 years ago

#2 Updated by phire almost 5 years ago

  • Assignee set to Anonymous
  • Regression changed from No to Yes
  • Operating system Windows added
  • Operating system deleted (N/A)

4.0-7538 is the move to visual studio 2015

#3 Updated by JMC4789 almost 5 years ago

Can you give some examples/a savefile of the transparent objects? Sounds like something that'd be easier for me to test. Also please upload a savefile that will let me see the glitch. Thank you!

#4 Updated by booto almost 5 years ago

http://www.gametdb.com/Wii/GQPE78 reports MD5 as 9e18f9a0032c4f3092945dc38a6517d3 not 5a8306706f932162ec39a05d4c5a443b.

Could you redump your disc and verify that:
1. You get that same MD5
2. The problem still occurs.

#5 Updated by Anonymous almost 5 years ago

redmine feature idea: periodically send emails to accounts which are blocking issues ;)

#6 Updated by JMC4789 almost 5 years ago

I kind of need an NTSC savefile showing a bug. I don't know this game and I played it for a while and it seemed fine.

#7 Updated by Disorderly almost 5 years ago

JMC4789 wrote:

I kind of need an NTSC savefile showing a bug. I don't know this game and I played it for a while and it seemed fine.

The following AR code will unlock all tasks automatically. They'll still have lock symbols, but you'll be able to access them just fine:

$All Tasks/Missions Unlocked
043C0E5E 3F800000

From here, just pause while in-game and scroll down through the missions until you see one called:

iNDUSTRiAL PARK

ROBO-PATRiCK AHOY!

Play that and you should be able to reproduce the bug.

#8 Updated by JMC4789 almost 5 years ago

Sounds good to me, will check it out.

#9 Updated by Anonymous almost 5 years ago

So, can the people who can repro the ZWW bug also repro this one?

#10 Updated by JMC4789 almost 5 years ago

Yeppers. Reproduced.

#11 Updated by Anonymous almost 5 years ago

  • Status changed from New to Duplicate

#12 Updated by JosJuice almost 5 years ago

#13 Updated by JosJuice almost 5 years ago

#14 Updated by mgracer48 over 4 years ago

are you guys going fix this

#15 Updated by Fog over 4 years ago

mgracer48 wrote:

are you guys going fix this

This is possibly separate from your issue as it's marked as Windows.

#16 Updated by mgracer48 over 4 years ago

so?
i think it can be both platforms
i want to know about updates about this

#17 Updated by JosJuice over 4 years ago

This problem has been fixed already, as you can see in issue 8930. And no, it's not for both platforms. That Apple would introduce the exact same C++ runtime bug as Microsoft did is so unlikely it might as well be impossible.

Also available in: Atom PDF