Project

General

Profile

Emulator Issues #8967

Can't use whole pre-existing Wii NAND with netplay and movie recording

Added by JosJuice about 5 years ago. Updated almost 2 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Project Moration (4.0-6512) improved the netplay and TAS experience by automatically using an empty NAND so that the NAND won't cause desyncs, but it also made it impossible to use non-empty NANDs (for those who are willing to sync it manually).

I couldn't remember if we already have an issue report for this, but I didn't find anything when searching, so I went ahead and made this. Please mark it as a duplicate if we already have one.


Related issues

Has duplicate Emulator - Emulator Issues #9134: Recording input causes dolphin to not read Wii save dataDuplicate

History

#1 Updated by JMC4789 about 5 years ago

  • Priority changed from Normal to Low

Yeah, the entire thing is a mess. I think what we're doing now is the best possible "easy" solution in that it will work with the least amount of work for the most usecases. TASers don't like using "dirty" saves anyway in most cases. They'll actually do a verification movie that plays up until a new-game plus run in most cases too. That would get around Dolphin's problem.

The bigger issue is that project moration actually breaks some games on netplay, and I wonder if that carries over into movie recording.

#2 Updated by JosJuice almost 5 years ago

#3 Updated by JosJuice over 3 years ago

  • Status changed from Accepted to Fix pending
  • Priority changed from Low to Normal
  • Milestone set to Current

Not a full solution (doesn't allow using the full NAND), but an improvement in functionality regardless: https://github.com/dolphin-emu/dolphin/pull/4546

#4 Updated by JosJuice over 3 years ago

  • Subject changed from Can't use pre-existing Wii NAND with netplay and movie recording to Can't use whole pre-existing Wii NAND with netplay and movie recording
  • Status changed from Fix pending to Accepted
  • Milestone deleted (Current)

That got merged in 5.0-2413, so save files for the initially booted game can now be used.

This issue is now tracking the ability to use a whole NAND if desired.

#5 Updated by JMC4789 almost 2 years ago

Is this issue fixed? We now allow sending saves (and whole NANDs!) on netplay. I don't know about movies.

#6 Updated by JosJuice almost 2 years ago

No.

Also available in: Atom PDF