Project

General

Profile

Emulator Issues #9013

Metroid Prime Trilogy XFB Virtual Black Screen Flickering

Added by TheVelocirapture almost 5 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Metroid Prime Trilogy

Game ID?

R3ME01

MD5 Hash?

823df1c3c425f1383529f368f6479359

What's the problem? Describe what went wrong.

Whenever I play Metroid Prime Trilogy with XFB Virtual (to avoid the black bar issue), the screen will at some point start to flash between the game and a completely black screen. Also performance is reduced to around 40 fps, but if I press the tab key to remove the framelimit then it will speed up to roughly 90 fps.

What steps will reproduce the problem?

1: Enable Virtual XFB
2: Start game
3: Create file, load file, click single player, Metroid Prime 1 (have not tested Prime 2 and Prime 3, issue likely exists in those games too), either difficulty (in theory should not have any effect)
4: Play the game, and at some point the screen will start to go epileptic and flicker between the game and a black screen every frame

One thing to note is it seems like the point where it starts flickering gradually shifts after each play of the game. E.G. first time you play it starts when Samus exits her ship, second time you play it starts when you enter gameplay, third time you play it starts when you enter the second room, etc.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 4.0-7943

What are your PC specifications?

Intel i5 4460 CPU
Gigabyte GeForce GTX 960 2GB
Windows 10 Pro
ASUS Z87 Motherboard
8GB of Ram

Is there any other relevant information?

None that I can think of.


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by Nerrel almost 5 years ago

I wanted to add that I'm having this issue and after briefly testing MP1 and MP3 I could not get the flickering to occur, so it seems this may be exclusive to Echoes. On my system, using the morph ball, scan visor, destroying objects with the arm cannon, or just simply progressing to new areas triggers the flickering. In other words, things similar to the actions that would trigger the black bar glitch/ GPU desync with XFB disabled.

4.0-7952
GTX 970
Windows 10 Pro
ASUS Z68 Pro 3 Gen 3 board
8GB RAM

#2 Updated by JMC4789 almost 5 years ago

Unfortunately, it appears that the way to avoid the black bar doesn't work for Metroid Prime 1 in Trilogy. Metroid Prime 2/3 seem to work for me though.

There is likely no fix; the fact that Virtual/RealXFB avoided the bug caused by a GPU desync is likely luck, unfortunately. This would just be filed along with the rest of the "Dualcore" issues.

#3 Updated by TheVelocirapture almost 5 years ago

I tested all 3 of them today. Prime 1 and Echoes have the flickering, Prime 3 does not. However, during my testing I noticed that XFB has this issue where the FPS counter says 60 and the game is running full speed, but the perceived smoothness is that of 30. In Prime 3 I just generally felt that it was unsmooth, so I went into Super Smash Bros Melee and the game was both unsmooth, and some animations had artifacts due to the 30 FPS (When Marth swings his sword, it's supposed to be one continuous white streak, but due to missing frames it looks like 3 individual shorter streaks). When using frame advance, instead of pressing the button once to advance one frame, pressing once visually does nothing but sound advances, then pressing again causes sound to advance again and visuals to advance 2 frames. This likely means that XFB is duplicating frames..

Should I make a separate issue report for the XFB framerate issue, or should we talk about that here because both issues are related to XFB?

#4 Updated by JMC4789 almost 5 years ago

That's an ancient bug. I'm sure booto is aware of it.

Regarding the new bugs, we have a lot of information so hopefully when booto gets time to look into it it'll get fixed.

#5 Updated by badkarma12 almost 5 years ago

@jmc4789

Pretty sure this is issue 9023. Which was broken by build 7864 along with a dozen other games. Not a dual core issue, happens even with it disabled.

#6 Updated by JMC4789 over 4 years ago

Unfortunately, it appears the black bar issue is only fixed in Metroid Prime 3(Trilogy 3 included) but not Metroid Prime 1/2 Trilogy. The flickering is fixed in single core within PR 3252.

#7 Updated by JMC4789 over 3 years ago

  • Status changed from New to Duplicate

#8 Updated by JMC4789 over 3 years ago

#9 Updated by JosJuice over 2 years ago

#10 Updated by JosJuice over 2 years ago

Also available in: Atom PDF