Project

General

Profile

Emulator Issues #9014

SUGGESTION: Implement Joystick Velocity Input for Wii Remote IR

Added by Anonymous almost 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Currently, the IR pointer position is based on a set value, which makes it very hard to control when it's mapped to regular buttons or an analog stick.
Shouldn't it be possible to contain the IR pointer's current position in memory and make adjustments to it via input?
On that topic, couldn't tilting and swinging use the same mechanic, dynamically shifting to upright and sideways positions?

It seems like adding the relative input option to the mapper will enable a lot of different control schemes and increase usability.


Related issues

Has duplicate Emulator - Emulator Issues #9181: Add Analog Joystick IR Like Xpadder(All Emulated Wiimote)Duplicate

Has duplicate Emulator - Emulator Issues #9666: Feature Request - Implement (Cursor X/Y-/+)-like feature for gamepadDuplicate

Is duplicate of Emulator - Emulator Issues #3033: Emulated wiimote cursor via analog stick not ideal (need relative cursor movement option)Fixed

History

#1 Updated by JosJuice almost 5 years ago

  • Status changed from New to Accepted
  • Issue type changed from Bug to Feature request

#2 Updated by pauldacheez almost 5 years ago

Don't we already have ten of this same feature request lying around? I'd probably hear about it every day if I still bothered with the forums.

#3 Updated by MayImilae almost 5 years ago

  • Status changed from Accepted to Questionable

snip

#4 Updated by Helios almost 5 years ago

I don't see the issue with this as long as it isn't default functionality.

#5 Updated by MayImilae almost 5 years ago

  • Subject changed from SUGGESTION: Implement relative IR input to SUGGESTION: Implement Joystick Velocity Input for Wii Remote IR
  • Status changed from Questionable to Accepted

This wouldn't work very well for Metroid Prime 3-like control style shooters, but velocity based input could work nicely in the wii menu and pointer titles. By velocity I mean that the cursor is more or less stuck in place, and the strength of the joystick direction controls its velocity in that direction, not its absolute location.

#6 Updated by Anonymous almost 5 years ago

I'm not sure why you would call it "velocity input", as it doesn't seem very intuitive for newcomers and may cause some confusion with some controllers' gyroscope function. I know it's technically correct as the joystick is controlling the displacement rather than absolute location, but there must be some better term for it.
In my experience, I've had some problems even with Metroid Prime 3 as you either had to completely center the target for it to lock on, or hold the stick in a certain position. This can get quite a bit frustrating when having to push 2-3 buttons while doing it. What prompted me to make a request, however, is the pull stars from Super Mario Galaxy/2, which turned from a benign and mindless experience to just tedious work.

Is there any way to implement the same solution for tilting and skewing? I think it would be helpful for games like Skyward Sword and Metroid: Other M.

#7 Updated by wildgoosespeeder over 4 years ago

What would be really impressive is if you could map the mouse pointer 1:1 with the Wii pointer.

#8 Updated by JMC4789 over 4 years ago

Each game does different things with Wiimote IR... so... no?

I mean, I'm sure anything is possible with emulated Wiimotes, but 1:1 probably won't happen because the position of the Wiimote displayed on screen depends on the game/software. That's the only reason it currently isn't 1:1 anyway.

#9 Updated by phire over 4 years ago

What would be really impressive is if you could map the mouse pointer 1:1 with the Wii pointer.

That's completely unrelated to this feature request, and not really possible as each game describes it's own mapping between IR and the pointer location on the screen.

#10 Updated by Anonymous over 4 years ago

I think this is good time as any to ask for updates about this suggestion. I mainly worry it'll not make 5.0 as many users don't use the dev builds, and its release date is currently TBD.

#11 Updated by JosJuice over 4 years ago

#12 Updated by Anonymous over 4 years ago

Seeing as it's past feature-creep deadline and no work has been done on it, is there any chance it will make it into 5.0?

#13 Updated by MayImilae over 4 years ago

We are in the feature freeze now, and would be a new feature, so it by definition cannot be added to 5.0.

#14 Updated by JosJuice over 4 years ago

  • Milestone set to Next

#15 Updated by JosJuice about 4 years ago

  • Milestone changed from Next to Current

5.0 was released, moving Milestone-Next to Milestone-Current.

#16 Updated by JosJuice about 4 years ago

  • Has duplicate Emulator Issues #9666: Feature Request - Implement (Cursor X/Y-/+)-like feature for gamepad added

#17 Updated by leoetlino almost 4 years ago

I think this is a duplicate of this old feature request (#3033).

PR 4010 makes an attempt at implementing this.

#18 Updated by JosJuice almost 4 years ago

  • Status changed from Accepted to Duplicate

You're right.

#19 Updated by JosJuice almost 4 years ago

  • Is duplicate of Emulator Issues #3033: Emulated wiimote cursor via analog stick not ideal (need relative cursor movement option) added

Also available in: Atom PDF