Project

General

Profile

Emulator Issues #9029

Contra ReBirth - Black Screen and freezes

Added by windows4ya over 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Contra ReBirth

Game ID? (right click the game in the game list, properties, info tab)

WKTEA4

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

75a8df9f52310fc81bf3716d19798616

What's the problem? Describe what went wrong.

Blackscreen after konami logo (With Store EFB Copies to Texture Only Enabled) and freezes on black screen after select continue on Gameover screen.
On dolphin 4.0-7630 With Store EFB Copies to Texture Only Disabled solved black screen problem but it's freezes on title screen with graphical giltches after skip the intro.

What steps will reproduce the problem?

Disable Store EFB Copies to Texture Only. (4.0-7630 or newer)
Use Dolphin 4.0-7626 or older.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Tested on
4.0-7983 (black screen)
4.0-7630 (black screen)
4.0-7626 work fine (No black screen)

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel Celeron B820
GPU: NVIDIA GeForce GT 620M
OS: Windows 8.1 Pro
6GB RAM usable 5.8GB

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Yes.

The game freezes on Title Screen with graphical giltches on dolphin 4.0-7630 With Store EFB Copies to Texture Only Disabled.

Title Screen.png (703 KB) Title Screen.png windows4ya, 10/12/2015 03:35 AM
4995

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by phire over 4 years ago

  • Assignee set to phire
  • Regression changed from No to Yes

So both freezing and black screen with "Store EFB Copies to Texture Only" disabled happen on the same PR?

Does it work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled?

#2 Updated by windows4ya over 4 years ago

phire wrote:

So both freezing and black screen with "Store EFB Copies to Texture Only" disabled happen on the same PR?

Does it work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled?

Yes. It's work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled and it's doesn't freeze after continue the game.

#3 Updated by windows4ya over 4 years ago

windows4ya wrote:

phire wrote:

So both freezing and black screen with "Store EFB Copies to Texture Only" disabled happen on the same PR?

Does it work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled?

Yes. It's work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled and it's doesn't freeze on black screen after continue the game.

#4 Updated by windows4ya over 4 years ago

windows4ya wrote:

windows4ya wrote:

phire wrote:

So both freezing and black screen with "Store EFB Copies to Texture Only" disabled happen on the same PR?

Does it work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled?

Yes. It's work on 4.0-7626 with "Store EFB Copies to Texture Only" disabled and it's doesn't freeze on black screen after continue the game.

#5 Updated by JosJuice about 4 years ago

  • Milestone set to Current

#6 Updated by JMC4789 about 4 years ago

This game has always been broken in dualcore. Just use single core and both EFB2Tex and EFB2RAM will work fine. It's just a slight behavior change in the crash.

#7 Updated by JMC4789 about 4 years ago

  • Milestone deleted (Current)

#8 Updated by JMC4789 about 4 years ago

  • Status changed from New to Duplicate
  • Parent task set to #7143

Because EFB Copies to RAM always crashed and now EFB Copies to Texture is acting more like EFB Copies to RAM, the fact it crashes on EFB Copies to texture is probably a good thing. Using single core will alleviate all issues regardless, so, I'm going to merge this into the dualcore timing issues issue.

#9 Updated by JosJuice about 4 years ago

  • Parent task deleted (#7143)

#10 Updated by JosJuice about 4 years ago

Also available in: Atom PDF