Project

General

Profile

Emulator Issues #9064

Disaster: Day of Crisis crashing

Added by Helios over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Disaster: Day of Crisis

Game ID? (right click the game in the game list, properties, info tab)

RDZP01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

729d8b13498dd0556d7423e49457a75a

What's the problem? Describe what went wrong.

https://forums.dolphin-emu.org/Thread-disaster-day-of-crisis-broken

The problem is initially described as build 4674 causing the game to crash after the loading screen. The OP then discovered that various builds caused the game to crash at various places. See the thread for details.

What steps will reproduce the problem?

For the loading screen crash, load the game up on 4674. apparently 4.0.2 doesn't crash but crashes somewhere else. Need to follow up with the poster and get more info.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Poster tested on 4674 and 4.0.2 at least. They said they tested on others as well and that caused different crashes

What are your PC specifications? (CPU, GPU, Operating System, more)

At minimum they were running x64, since they were using dev releases. If their profile is up to date, they're on Windows 8 with an AMD CPU and an nvidia GPU.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

https://forums.dolphin-emu.org/Thread-disaster-day-of-crisis-broken

They did a good job bisecting that initial crash but apparently the game is Very Broken elsewhere too.

JMC if you could work your testing magic?...


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 over 3 years ago

I don't have the game so there's not much I can do.

#2 Updated by markwest76 over 3 years ago

Interesting to notice that the Dx plugin of the Ischiiruka branch seems much more stable (played the whole first two levels w/o problems) than the master one (lot of black screens)...maybe someone should investigate why that is happening...

#3 Updated by JMC4789 over 3 years ago

You could try single core and whatnot if you haven't. The biggest difference between ishiiruka is how they won't block the GPU thread for shaders with async shaders on. single core removes the dualcore timing issues.

#4 Updated by markwest76 over 3 years ago

Well it could be, because Ishiiruka with OpenGL crashed the same way as master...so for now I'm gonna test a bit master single core and then report back

#5 Updated by markwest76 over 3 years ago

Ok, seems like master needs single core option enabled to avoid random crashes (black screens) in this game: played whole third level using OpenGL Single Core without any problem.
Also note that the game in single core mode performed very good (with an old CoreDuo e8600 I was generally at 160-170% speed uncapped) even better with new experimental DX12 plugin (funny to notice that DX12 Single Core mode is almost as fast as DX11 Dual Core :-) )...so maybe the option could even be set by default in game.ini (if not, at least a note to inform that Disaster: Day of Crysis in Dual Core mode is unstable).

#6 Updated by JMC4789 over 3 years ago

  • Status changed from New to Duplicate

Cool, solved!

#7 Updated by JMC4789 over 3 years ago

#8 Updated by JMC4789 over 3 years ago

please add this game to the issue I linked it to.

Also available in: Atom PDF