Project

General

Profile

Emulator Issues #9079

Controllers only work when they're plugged before the emulator starts

Added by Juesto over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

As title says: i cant use the controller despite controllers settings showing the correct controller and clicking refresh crashes the emulator sometimes.

What steps will reproduce the problem?

(wireless xbox 360 controller for windows here)
1) turn it off but leave the receiver plugged
2) open dolphin and run a game or menu
3) turn the controller back on
4) attempt to use it
4a) go in controllers -> configure and attempt to refresh

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?
Had this problem since 4xxx builds, i doubt if this wasn't broken on a older version.


Related issues

Is duplicate of Emulator - Emulator Issues #6047: XInput Hotplug doesn't workFix pending

History

#1 Updated by skidau about 3 years ago

  • Status changed from New to Duplicate
  • Parent task set to #6047
  • Issue type changed from Bug to Feature request

#2 Updated by skidau about 3 years ago

  • Parent task deleted (#6047)

#3 Updated by skidau about 3 years ago

Also available in: Atom PDF