Project

General

Profile

Actions

Emulator Issues #9084

closed

Metroid Prime Trilogy - Metroid Prime infinite Warning messages: "Memory stride is too small"

Added by KennyL84 over 8 years ago. Updated about 8 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Metroid Prime Trilogy]

Game ID? (right click the game in the game list, properties, info tab)

[R3ME01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[7c53139a65f3e58da16d883cba8ca8ba]

What's the problem? Describe what went wrong.

[Switching to Visor mode in Metroid Prime 1 will generate a warning message which is prompting: "Memory stride is too small" "Yes" or "No". By clicking "yes" the game moves just one frame and generates the same message again. By clicking "no", Dolphin would crash. Thus leaving the game unplayable.]

What steps will reproduce the problem?

[The earliest possible event would be to start Metroid Prime 1. Wait for the cutscene to finish and switch to Visor mode by holding "-" on the wiimote and moving the cursor to the top part of the HUD then releasing the "-" button and the warning message will pop up. ]

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[4.0-8137. This is happening since version 4.0-8059 "TextureCacheBase: Change CacheLinesPerRow to BytesPerRow (PR #3188 von lioncash)" Turning off the hacks won't help.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[CPU: AMD Phenom II X4 965 @ 3.7GHz
GPU: NVIDIA GeForce GTX 660
OS: Windows 7 x64 Ultimate
RAM: 4 GB]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]


Related issues 1 (0 open1 closed)

Is duplicate of Emulator - Emulator Issues #8956: Memory stride is too smallFixedphire

Actions
Actions #1

Updated by JMC4789 over 8 years ago

  • Status changed from New to Accepted
  • Priority changed from Normal to High
  • Parent task set to #8956

Turn off panic handlers for the time being; the bug is being looked into.

Actions #2

Updated by kolano about 8 years ago

Shouldn't this be merged with 8956?

Actions #3

Updated by MayImilae about 8 years ago

  • Parent task deleted (#8956)
Actions #4

Updated by MayImilae about 8 years ago

Actions #5

Updated by MayImilae about 8 years ago

  • Status changed from Accepted to Duplicate
Actions #6

Updated by MayImilae about 8 years ago

  • Status changed from Duplicate to Accepted
Actions #7

Updated by MayImilae about 8 years ago

Actions #8

Updated by MayImilae about 8 years ago

Actions #9

Updated by MayImilae about 8 years ago

  • Status changed from Accepted to Duplicate

I asked delroth, and he said these issues should be marked as duplicates, just as we have always done. So, correcting!

Actions #10

Updated by MayImilae about 8 years ago

Actions #11

Updated by MayImilae about 8 years ago

Actions

Also available in: Atom PDF