Project

General

Profile

Emulator Issues #9087

Super Mario Sunshine - Shaky Bridge in Bianco Hills

Added by wildgoosespeeder about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Mario Sunshine

Game ID? (right click the game in the game list, properties, info tab)

GMSE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

0c6d2edae9fdf40dfc410ff1623e4119

What's the problem? Describe what went wrong.

Bianco Hills has a very shaky bridge on to the way to the windmill. I can see it as disorienting and nauseating to some players. I think this happens on other props as well because I saw some shaky behavior with signs playing in Ricco Harbor too.

What steps will reproduce the problem?

Play Bianco Hills and pick any scenario. Go to the bridge. Move the camera around with the c-stick or get Mario to move.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-8133 thru 4.0-8140

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 8.1
Intel Core i5-3210M @ 2.5GHz
NVIDIA GeForce 610M
12GB PC3-12800

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

N/A

Movie.wmv (4 MB) Movie.wmv Super Mario Sunshine Bridge wildgoosespeeder, 11/14/2015 01:18 AM

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

Has duplicate Emulator - Emulator Issues #9118: Mario Sunshine Bianco Hills (second shine) bridge fluctuates positionsDuplicate

History

#1 Updated by JMC4789 about 4 years ago

Are you sure that's not just the rampant heatwave effect in the game???

#2 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

Are you sure that's not just the rampant heatwave effect in the game???

I'm pretty sure it's an issue with Dolphin because the heatwave effect applies to distant objects. This is very close to the camera. I tested on real hardware just to be absolutely sure and no, the real hardware doesn't have this issue.

#3 Updated by JMC4789 about 4 years ago

I'm standing on the bridge right now and it's not shaking, so, I'm going to need more clear instructions.

#4 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

I'm standing on the bridge right now and it's not shaking, so, I'm going to need more clear instructions.

Try jumping on the cables. There's also cables below the bridge. I jumped on the below cables while the camera was pointing to the bridge. I think the effect is a bit more noticeable there. Try with the very first scenario of Bianco Hills.

#5 Updated by JMC4789 about 4 years ago

I'll look into this more when I get a few moments, hold tight. There are apparently other reports of stuff like this happening, but, through all my playthroughs of the game I've never seen it. Can you try various accuracy settings while you wait for me?

#6 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

I'll look into this more when I get a few moments, hold tight. There are apparently other reports of stuff like this happening, but, through all my playthroughs of the game I've never seen it. Can you try various accuracy settings while you wait for me?

Already did. It seems like enabling the bounding box fixes the issue initially but when I close Dolphin, open Dolphin, make sure to enable bounding box, and then start Super Mario Sunshine, the problem is back.

#7 Updated by JMC4789 about 4 years ago

Are you sure it's not opening the graphics menu (and overriding some setting) that's actually "fixing" it?

#8 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

Are you sure it's not opening the graphics menu (and overriding some setting) that's actually "fixing" it?

Following settings as stated on the Dolphin Wiki.

#9 Updated by JMC4789 about 4 years ago

  • Status changed from New to Questionable

I cannot reproduce the issue. The game does shake a bit when you move the c-stick (bad deadzone?) but, that also happens on console.

Unless you can pin the bug on Dolphin, I'm going to have to close this issue.

#10 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

I cannot reproduce the issue. The game does shake a bit when you move the c-stick (bad deadzone?) but, that also happens on console.

Unless you can pin the bug on Dolphin, I'm going to have to close this issue.

I have smooth camera motion that isn't the bridge when using the c-stick or bouncing on the wires as I have said. You said it yourself; there are reports of this behavior before. Can I get a different person if you can't reproduce the issue? I swear the issue is there and it is just a minor cosmetic blemish on an otherwise 4-star rated game for Dolphin compatibility. I can play the game just fine. I can see this being a potential issue for others if it doesn't get fixed; the ones that get motion-sick more easily.

#11 Updated by Helios about 4 years ago

wildgoosespeeder wrote:

Can I get a different person if you can't reproduce the issue?

We are not customer support. This is a game bug that is on console as well.

Issue closed.

#12 Updated by Helios about 4 years ago

  • Status changed from Questionable to Invalid

#13 Updated by JMC4789 about 4 years ago

Looks like it does this on console here. If you're still unsure, try using FPRF.

#14 Updated by wildgoosespeeder about 4 years ago

Helios wrote:

wildgoosespeeder wrote:

Can I get a different person if you can't reproduce the issue?

We are not customer support. This is a game bug that is on console as well.

Issue closed.

I get the feeling we aren't looking at the right thing. I also get the feeling we might be playing two very different versions of Super Mario Sunshine. I happen to have dumped a Player's Choice version of the game. I will also provide a video demonstration. Didn't think I would need to do that. Attached is a video demonstration (compressed from 400MB to 4MB).

#15 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

Looks like it does this on console here. If you're still unsure, try using FPRF.

That doesn't work. I uploaded a demonstration.

#16 Updated by wildgoosespeeder about 4 years ago

Here is what the bridge should be doing (video from 2008 from real hardware):
https://www.youtube.com/watch?v=QZXA_IcF_Uo

#17 Updated by delroth about 4 years ago

  • Status changed from Invalid to Questionable

JMC, please re-triage this issue. Thanks!

#18 Updated by marzipanWhale about 4 years ago

I can reproduce this issue, but only at higher internal resolutions. I start seeing it a 3x and it gets worse as I go higher.

Using 4.0-8163
intel i7-3770
GTX 560 Ti
Windows 10

#19 Updated by JMC4789 about 4 years ago

My testing (and likely MaJoR1's knowing how we all use accuracy settings for testing) were on 1x IR.

If Marzipan can only confirm at higher IRs, I'd like to reclose this issue.

Wildgoosespeeder: Can you try this at 1x IR?

#20 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

My testing (and likely MaJoR1's knowing how we all use accuracy settings for testing) were on 1x IR.

If Marzipan can only confirm at higher IRs, I'd like to reclose this issue.

Wildgoosespeeder: Can you try this at 1x IR?

Everything was at default settings and GameINIs overrode settings automatically where necessary. My hardware isn't powerful enough and slows down emulation significantly if I go above 1x native. This bug is quite strange because of its possible inconsistency. I don't know what is causing it.

#21 Updated by marzipanWhale about 4 years ago

After further testing I find that I can only reproduce when dolphin is struggling to keep up. Setting higher IR or anti aliasing usually works.

The issue also seemingly goes away if you run in Single Core mode.

#22 Updated by JMC4789 about 4 years ago

  • Status changed from Questionable to Duplicate

This is a dualcore desync issue due to your computer not being powerful enough, cool. At least this is solved.

#23 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

This is a dualcore desync issue due to your computer not being powerful enough, cool. At least this is solved.

What settings should I manipulate? Should I manipulate disabling dual core mode or should I enable sync GPU thread?

#24 Updated by JMC4789 about 4 years ago

I always prefer using single core mode over syncGPU for testing.

Basically, it seems as though this issue manifests itself when the threads are stressed/desyncing due to one thread falling behind the other. On a faster PC under no lag, it would make sense for it to not happen even in Dualcore. Considering we already know Mario Sunshine is dualcore sensitive... yeah, this all makes sense.

If you can still reproduce it on single core, then I'll be pretty shocked.

#25 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

I always prefer using single core mode over syncGPU for testing.

Basically, it seems as though this issue manifests itself when the threads are stressed/desyncing due to one thread falling behind the other. On a faster PC under no lag, it would make sense for it to not happen even in Dualcore. Considering we already know Mario Sunshine is dualcore sensitive... yeah, this all makes sense.

If you can still reproduce it on single core, then I'll be pretty shocked.

For the Wiki's sake, you flagged this as a duplicate issue. Where is the earliest known bug report of this kind of behavior?

#26 Updated by JMC4789 about 4 years ago

I flagged it as a duplicate because there are billions of dualcore issues in Dolphin. It's the biggest hack in the emulator as far as I'm concerned. issue 7143 is my master issue for dualcore stuff.

#27 Updated by JosJuice about 4 years ago

#28 Updated by wildgoosespeeder about 4 years ago

JMC4789 wrote:

I flagged it as a duplicate because there are billions of dualcore issues in Dolphin. It's the biggest hack in the emulator as far as I'm concerned. issue 7143 is my master issue for dualcore stuff.

Anyways, thanks for the help. I am not experiencing that shaky bridge anymore but at a cost of having the emulation run more slowly for disabling dual core mode or syncing GPU thread. Is there any way to fix the code to not require the setting or is that impossible?

#29 Updated by JosJuice about 4 years ago

  • Has duplicate Emulator Issues #9118: Mario Sunshine Bianco Hills (second shine) bridge fluctuates positions added

Also available in: Atom PDF