Project

General

Profile

Emulator Issues #9101

[Feature] Ability to select audio output device from within Dolphin

Added by wildgoosespeeder almost 5 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
Yes
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

One of my computers supports multiple sound-out devices (integrated audio and the graphics card if using an HDMI connection). A program like VLC Media Player has support to direct decoded sound to the default sound-out device or specifically a certain sound-out device that isn't necessarily default. I'm pretty sure this is thanks to DirectSound API. This would be a great feature for those who want to run Dolphin Emulator to their TVs or something without having to change their default sound-out device through the use of Volume Control Options. Attached is an example of two sound-out devices.

Untitled.png (19.3 KB) Untitled.png Volume Control Options example wildgoosespeeder, 11/18/2015 02:08 AM
5036

Related issues

Is duplicate of Emulator - Emulator Issues #5976: Add ability to choose audio output device.New

History

#1 Updated by phire almost 5 years ago

  • Status changed from New to Invalid
  • Issue type changed from Bug to Feature request

DirectSound has been replaced as an API by XAudio.

Older versions of dolphin had a directsound backend. They didn't have the feature to direct audio to a certain output device.

#2 Updated by wildgoosespeeder almost 5 years ago

phire wrote:

DirectSound has been replaced as an API by XAudio.

Older versions of dolphin had a directsound backend. They didn't have the feature to direct audio to a certain output device.

Then what am I thinking of at allows for the ability I am asking? Also does that mean that XAudio2 can do what I am requesting? If so, where is that option in the emulator?

#3 Updated by MayImilae almost 5 years ago

dsound was removed in 4.0-2717.

#5 Updated by wildgoosespeeder almost 5 years ago

MaJoRoesch wrote:

dsound was removed in 4.0-2717.

Why? I'm curious. Is it because of a GPL conflict?

#6 Updated by pauldacheez almost 5 years ago

No, it was just a shitty backend at that point.

#7 Updated by phire almost 5 years ago

No point supporting both DirectSound and the XAudio API which replaces it.

#9 Updated by phire almost 5 years ago

No

#10 Updated by parlane almost 5 years ago

  • Subject changed from Feature Request - DirectSound (Not As Backend) to [Feature] Ability to select audio output device from within Dolphin

#11 Updated by wildgoosespeeder almost 5 years ago

phire wrote:

No point supporting both DirectSound and the XAudio API which replaces it.

TIL that XInput replaced DirectInput as XAudio replaced DirectSound. I had a feeling that anything DirectX is potentially depreciated. The more you know.

#12 Updated by wildgoosespeeder almost 5 years ago

pauldacheez wrote:

No, it was just a shitty backend at that point.

Kind of like the OpenAL backend at times (Pokémon XD has delayed audio for some reason using OpenAL on the Wiki page)?

#13 Updated by wildgoosespeeder almost 5 years ago

phire wrote:

No

Seems like Parlane changed the title to be more suitable to what I am requesting. Change the status to not be invalid please?

#14 Updated by parlane almost 5 years ago

  • Status changed from Invalid to New
  • Priority changed from Normal to Low
  • Relates to usability changed from No to Yes
  • Operating system Windows added
  • Operating system deleted (N/A)

#15 Updated by degasus almost 5 years ago

I'm not sure if we want to support this feature. In my opinion, the OS mixer should be able to move audio stream on the fly, so no application should need to care about it...

#16 Updated by Helios almost 5 years ago

I'm not in favor of making an application ignore OS settings.

If you want an audio switcher, https://github.com/Belphemur/SoundSwitch

#17 Updated by mstreurman almost 5 years ago

I would very much like this feature: I'm running a laptop which is connected to my TV as a second screen using a long HDMI-cable and 2 Wireless 360 controllers. TV is in the Lounge and my laptop is in my own bedroom next to it. I'm living with 3 other people who like to play a game every now and then, when I'm in my room listening to music. So to be able to select from within Dolphin that the sound should go through my HDMI cable to the TV so that I don't have to change the default sound output for my music would be completely awesome. Now I have to use a different device to listen to my music since all the sounds go to the living room through HDMI.

#18 Updated by wildgoosespeeder almost 5 years ago

wickmarkus86 wrote:

I'm not sure if we want to support this feature. In my opinion, the OS mixer should be able to move audio stream on the fly, so no application should need to care about it...

Well then, you sacrifice usability and convenience.

Helios wrote:

I'm not in favor of making an application ignore OS settings.

If you want an audio switcher, https://github.com/Belphemur/SoundSwitch

It's about native support.

#19 Updated by leoetlino about 3 years ago

#20 Updated by leoetlino about 3 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF