Project

General

Profile

Emulator Issues #9106

Nunchuk Seems To Confuses Wii Sports Resort If MotionPlus Is Connected (even when using a Wii RemotePlus)

Added by Anonymous almost 4 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Wii Sports Resort]

Game ID? (right click the game in the game list, properties, info tab)

[RZTP01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[3aabcdd66c89a8d6d1d4c9eb7003e6ef]

What's the problem? Describe what went wrong.

[I'm using a Non-'TR' Wii RemotePlus with a Nunchuk, along with MayFlash's DolphinBar (latest Firmware, Firmware date September 2nd).

Sometimes, when starting up Wii Sports Resort with a Nunchuk connected, Wii Sports Resort thinks there's no MotionPlus attachment connected, even when using a Wii RemotePlus. There also seems to be some odd behavior sometimes when ending emulation of Wii Sports Resort and starting it up again without closing out of the Dolphin Menu beforehand, that also seems to trigger the same issue, even without the Nunchuk connected.

Ending the emulation and restarting Wii Sports Resort/quitting out completely of Dolphin can fix the issue, but the glitch is an inconvenience to resolve via trial and error. Sometimes you ultimately have to quit out of Dolphin and open it up again, yet even this may not work. It is often solved via trial and error. A good way to solve the glitch is starting the game up and connecting the Nunchuk when at the 'Select Players' screen.

When the glitch occurs, whilst looking at the select players screen, the game can't even detect the Nunchuk being disconnected. It seems that the detection freezes, or something. I also believe when the glitch occurs, it affects the entire game session, even games that don't use the Nunchuk.]

What steps will reproduce the problem?

[1. Open Wii Sports Resort with a Nunchuk connected

  1. Open up a game that uses the Nunchuk such as Archery, or Cycling.

  2. The remote status images in the 'Select Players' screen show a Wii Remote and a Nunchuk, but no 'MotionPlus' attachment and no confirmation 'OK!' message.]

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[4.0-8010]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Intel i5 2320, ASUS STRIX GeForce GTX 750 Ti, Windows 10 Pro Threshold 2 (Version 1511, OS Build 10586.11)]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[2 screenshots down below]

wiimotionplusglitch1.PNG (715 KB) wiimotionplusglitch1.PNG When the glitch occurs. (Note that the game thinks there is no MotionPlus attachment 'connected', even when using a Wii RemotePlus) Anonymous, 11/19/2015 08:20 AM
wiimotionplusglitch2.PNG (708 KB) wiimotionplusglitch2.PNG The glitch resolved due to trial and error (Note that it now shows that the 'MotionPlus' attachment is 'connected'). Anonymous, 11/19/2015 08:22 AM
5040
5041

Related issues

Is duplicate of Emulator - Emulator Issues #9592: Wii Remote extensions are not detected properly with MotionPlus and Emulated BluetoothDuplicate

History

#1 Updated by JMC4789 almost 4 years ago

Yeah, this game is weird about that. Sometimes dumping my NAND from a Wii affects it, but then eventually the behavior will return.

#2 Updated by Anonymous almost 4 years ago

I can confirm that the Nunchuk being plugged in whilst the game is starting seems to cause the issue.

When you start the game without the Nunchuk plugged in, MotionPlus is detected without any issues. Plugging in the Nunchuk when needed doesn't cause any issues, the game just needs to start without it plugged in for some reason.

#3 Updated by Anonymous almost 4 years ago

EDIT: Just tested again, the glitch only occurs when you enter the 'Select Players' screen with the Nunchuk connected for the first time, then seems to affect the whole session until you quit out of Dolphin (my bad).

#4 Updated by leoetlino almost 2 years ago

  • Status changed from New to Duplicate

#5 Updated by leoetlino almost 2 years ago

  • Is duplicate of Emulator Issues #9592: Wii Remote extensions are not detected properly with MotionPlus and Emulated Bluetooth added

Also available in: Atom PDF