Project

General

Profile

Emulator Issues #9120

Donkey and Diddy Kong 3D models flicker and turn invisible

Added by maplelink almost 7 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Donkey Kong Country Returns

Game ID? (right click the game in the game list, properties, info tab)

SF8E01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

6ff36b6b6b8a42064e73847993c43e4b

What's the problem? Describe what went wrong.

The Donkey and Diddy Kong 3D models flicker and turn invisible when playing in almost any level

What steps will reproduce the problem?

On the map screen, select any stage and once the level has been loaded, the models will start flickering

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-8000 Working
4.0-8098 Not working

What are your PC specifications? (CPU, GPU, Operating System, more)

Window 10 Pro
Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz
GeForce GTX880M
32.0 GB RAM
64-bit OS

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

See attached files.

dkrbug01.png (20.2 KB) dkrbug01.png maplelink, 11/26/2015 07:32 AM
dkrbug02.png (20.5 KB) dkrbug02.png maplelink, 11/26/2015 07:32 AM
dkrbug04.png (16.6 KB) dkrbug04.png maplelink, 11/26/2015 07:32 AM
dkrbug03.png (19 KB) dkrbug03.png maplelink, 11/26/2015 07:32 AM
SF8E01-1.png (395 KB) SF8E01-1.png seapancake, 12/07/2015 12:53 PM
SF8E01-2.png (399 KB) SF8E01-2.png seapancake, 12/07/2015 12:53 PM
SF8E01-7.png (402 KB) SF8E01-7.png seapancake, 12/07/2015 12:53 PM
SF8E01-9.png (405 KB) SF8E01-9.png seapancake, 12/07/2015 12:53 PM
SF8E01-12.png (392 KB) SF8E01-12.png seapancake, 12/07/2015 12:53 PM
5069
5070
5071
5072
5084
5085
5086
5087
5088

Related issues

Is duplicate of Emulator - Emulator Issues #8951: Resident Evil 4's smoke/dust effects are squaresFixed

History

#1 Updated by seapancake almost 7 years ago

5084
5085
5086
5087
5088

#2 Updated by seapancake almost 7 years ago

Looks to be an open issue here https://github.com/dolphin-emu/dolphin/pull/3266

#3 Updated by JosJuice almost 7 years ago

  • Milestone set to Current

#4 Updated by skidau over 6 years ago

  • Regression changed from No to Yes

#5 Updated by Armada over 6 years ago

  • Status changed from New to Fix pending

#6 Updated by JMC4789 over 6 years ago

  • Assignee set to mimimi

#7 Updated by Fog over 6 years ago

  • Status changed from Fix pending to Duplicate

Marking as duplicate as it's the same issue as the Resident Evil 4 issue.

#8 Updated by Fog over 6 years ago

Also available in: Atom PDF