Project

General

Profile

Emulator Issues #9143

Add "Hotkey" icon to toolbar

Added by Lucario over 4 years ago. Updated over 4 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

It's highly configurable and I've found myself having to go to there constantly to edit hotkeys for controller and keyboard. Why not shortcut to it from the Dolphin toolbar?

History

#1 Updated by MayImilae over 4 years ago

Unfortunately, the way the GUI currently is, any shortcuts added to the toolbar apply to all users, without any possible customization! As long as that is the case, anything we consider for the toolbar has to be weighed on how it will affect all users, positive and negative.

Personally, I believe that this is a poor choice for the toolbar, at least the uncustomizable one we have now. To my knowledge, most users do not interact with the hotkey menu at all, and if they do, they edit the hotkeys to change what they want and then leave it alone (as is intended). The toolbar shortcuts are for things most users will use a lot, or things we very much need them to discover (like graphics settings, paths, etc). I do not think this qualifies. :/ And I think the increased discoverability of a relatively advanced option would not be good for the bulk of Dolphin's userbase.

Of course, if the GUI is changed to allow customizable toolbar shortcuts, I'd be perfectly fine with this as a non-default toolbar shortcut option!

#2 Updated by Lucario over 4 years ago

I am aware this will apply change to all users. Without knowing how many people want this changes we can't tell for sure unless we make up poll for it. Sounds good?

I edit hotkey many times especially on my two PC's and sometimes to another user profile on the same computer, it never end, so let's not say that hotkey users like me will be done with it when we're really satisfied with it. We will eventually go there once again, even if we don't intend to edit hotkeys there. You might guessed correctly, it's when we forgot what key to press for such hotkey! Happened to me many time too. It's relevant to the users who left hotkeys default also.

#3 Updated by MayImilae over 4 years ago

First of all, polls are terrible ways to get information (to the non-expert poll giver) - there are a great many variables that need to be controlled, and then people don't vote what they are doing, just what they think they are doing. They might think they use it a bunch, when in fact they hardly ever touch it! The only way to really know would be some sort of analytics added to Dolphin. :/ Plus, the forum only provides input from forum users, which have joined the community and are more immersed in dolphin than the usual user! It is not anything close to a proper sampling.

Secondly, with GUI defaults, we have to weigh the pros and cons for every single user! How would forum members know anything about other users? They'd simply be responding regarding their own likes. Which is not appropriate for this kind of consideration. What is needed is thought and debate among those that know things about GUIs and the users, designers, core staff, and developers, to work through and carefully weigh the benefits and harms of options, and settle on a decision. Forum goers don't have the weight of the wrong decision on them, and are just going to vote on whatever pleases them, which unfortunately is not a useful metric since it's such a tiny sampling of an unusual minority of the userbase.

Lastly, argumentum ad populum is pretty much the norm in public polls...

Don't make a poll. >_<

#4 Updated by Lucario over 4 years ago

Wasn't aware poll is such bad decision...

#5 Updated by MayImilae over 4 years ago

wrote this in an edit, no breaking off in a new post

Anyway, I have not seen you weighing anything of other users considerations into this. From all evidence and experience I have, the VAST majority of users only use the default keys, and even then only a basic set - they use the GUI primarily. What reasoning is there to add a button to the GUI that most users would not use? Especially when there are better ways.

Like, why don't you ask for a hotkey to open the hotkey menu? Wouldn't that get you want you want without bothering the GUI? I would be fine with that, it wouldn't harm user experience for the majority at all (as long as it is not set to something by default, or is a default that won't be confused!). EDIT: Ok that's probably not a great idea either...

#6 Updated by pauldacheez over 4 years ago

  • Status changed from New to Won't fix

This has "MaJoR says no" quite literally written all over it, and I agree that this is unnecessary or at least not the right direction if we want to actually improve our UI.

#7 Updated by Lucario over 4 years ago

Honestly, we may be biased here. I'd prefer to leave this an "open issue" for more commenters to throw their opinions on this. This may be a realistic feature request worth looking into.

#8 Updated by pauldacheez over 4 years ago

Not every user-generated idea is a good idea. Like, really, this saves you a click and some mouse movement, but it gives a new user something to waste an extra hour looking at and trying to comprehend (because configuring our hotkeys right now is waaaaaaaaay too complex for what it's supposed to be) when they don't actually need to change anything from the defaults or benefit from it much compared to the cost of learning how to configure hotkeys.

Besides, the current hotkey system has a dozen other problems that need a lot more attention and would just be exacerbated by a giant neon-lit arrow attracting new users' fingers to this mousetrap in the UI.

Considering that MaJoR actually knows a thing or two about UI design (hey, guess what she does for a living), I don't mind if there's some "bias" towards her opinions being perceived as correct, especially if I'm around to disagree on the occasional point I find flaws in.

#9 Updated by Lucario over 4 years ago

You've got really good point here. It's like stashing away the options deep into menu where the new users weren't supposed to see and waste their time there.

On the other hand, the ignorant users shouldn't influence on how GUI and menu should look on Dolphin. Shouldn't it be okay to "neon-lit arrow" on the broken menu? They're broken. They'll need to be fixed eventually.

Also poor point of Hotkey Setting to not have a Hotkey icon because it's complicated and hard to learn. It's the very reason why I need Hotkey icon for it and the intelligent users will know not to bother going there if they don't need it.

Hotkey as icon has its pros too. Like becoming more symmetric with Dolphin's "Options" menu (still needs to get rid of that Audio Setting from the menu), easy access to Hotkeys setting, and the new users will discover about it and will be thankful for that.

#10 Updated by Lucario over 4 years ago

The only strong point that detract this idea is the ignorant users making the false issue reports, right?

#11 Updated by MayImilae over 4 years ago

There is no need for symmetry with the Options menu - the menu bar is a completely different class of GUI element, the options aren't supposed to be the same as what it is in the toolbar!

According to Win9x techniques, the menu bar is the primary GUI interaction element, all navigable elements have to be there. But the toolbar exists to provide shortcuts to the most commonly used options in the GUI.

So following that, the hotkeys menu is not used by most of our users, nor is it meant to, and so it shouldn't be a toolbar shortcut. Since it is not customizable, we as curators of the emulator have to make the decision to do what is included or not according to what best for the majority, even if it inconveniences some. :/

#12 Updated by Lucario over 4 years ago

"Most commonly used options" has two different senses. It's most commonly used by majority and by hotkey users.

Saying that it isn't meant to be used by people sounds very biased. The freelook and fullscreen needs it and there are some good features that's much better used with hotkeys like save states / frame speed for TAS users.

#13 Updated by Lucario over 4 years ago

I take back the last sentence. People may go there and configure the fullscreen hotkey and then be stuck with it if they forgot what hotkey is it again :P

#14 Updated by Lucario over 4 years ago

I'd like to edit my post but that doesn't seem possible

So, uhh, wanted to say that while "hotkey menu" isn't used by majority, I don't see how is it not meant to either, save for the ignorant users. Should we take the ignorant users into account?

#16 Updated by MayImilae over 4 years ago

What phire was asking for there was additional education, but as I responded, there isn't really education that can be provided. The only reason to have a guide would be to inform users that the functionality exists, which we might need to do. There is a case to be made that it should be moved out of the Options menu (that was a recent move) but that is a very different discussion.

Regardless, the facts still stand. This is an advanced function, it is unfriendly to users who would stumble around and not know how to configure it. And that's ok, its an advanced function and dumbing it down to make sure all users can use it would just irritate advanced users while still not being good enough for casual users. It is what it is. Nevertheless, it is an advanced function and if it was placed front and center within the interface it would cause more harm than good.

Anyway, this discussion isn't going anywhere... In the future, the intention is for users to be able to customize the shortcut toolbar and place anything they want on it. When the ability for users to add things to the toolbar is possible, you can do whatever you want with your copy of Dolphin. But it would be a mistake to promote hotkeys to the toolbar by default at this time or any other time.

#17 Updated by Lucario over 4 years ago

It's your opinion to say it's a mistake to add it to the toolbar by default. It's a good opportunity to see if anyone complains! Then implement a way to edit the toolbar. I've thought of nice idea how to edit toolbar. It's about finding if a icon file exists. If it does, the button will appear on the toolbar rather than throwing an error message. After this is implemented (I bet it's gonna be hard right? I heard that it's hard because of this WX thing) you can just remove the hotkey icon file and then if someone wanted the hotkey button again they would just have the hotkey icon file in their theme folder.

Also available in: Atom PDF