Project

General

Profile

Emulator Issues #9160

AC - City Folk - bugged water cause invisible fish

Added by SirBanjo about 4 years ago. Updated over 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Animal Crossing: City Folk

Game ID?

RUUP01

MD5 Hash?

9FB1D28D924C9A776BD1DBF4B1CC8A49

What went wrong?
The water in the sea seems bugged. It's too light and not transparent enough.
The problem is that you can't see the fish in it. River seems to work fine.

What steps will reproduce the problem?
1. start AC-City Folk
2. load your save-game
3. go to the sea

too make the fish visible but the water even more bugged:
- change graphics settings like "Anisotropic Filtering" when ingame

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-8329 (64bit)

Dolphin stable 4.0.2 displays the water, as far as i know, correct but tends to crash occasionally. (screenshots following)

What are your PC specifications?

Intel Core-i5 3570k @ 4.0 GHz
AMD Radeon R9 280X - (Radeon Software Version 15.11.1)
RAM: 8 GB
Windows 10 x64

2nd system:
Intel Core-i7 3770K @ 4.2 GHz
AMD Radeon HD 7850 - (Radeon Software Version 15.11.1)
RAM: 16 GB
Windows 10 x64 (1511)

**Is there any other relevant information?

water how it should look - Dolphin 4.0.2 stable
http://imgur.com/vkbMTIx

bugged water - 4.0-8329 :
http://imgur.com/pObfeur
fish invisible

when changed graphics settings - 4.0-8329:
http://imgur.com/jLXnGyk
fish visible again, more glitched water

accf.dff.gz (2.02 MB) accf.dff.gz fifolog marvinl97, 12/18/2015 02:34 PM
RUUP01-2.png (1.09 MB) RUUP01-2.png seapancake, 12/21/2015 01:01 PM
RUUP01-1.png (1.22 MB) RUUP01-1.png seapancake, 12/21/2015 01:01 PM
RUUP01-4.png (1.37 MB) RUUP01-4.png seapancake, 12/21/2015 01:01 PM
5124
5125
5126

History

#1 Updated by marvinl97 about 4 years ago

I tested 20+ different revisions and found the revision which introduced this bug. At 4.0-1192 the water starts bugging. The previous revision 4.0-1146 is fine.

4.0-1192: https://de.dolphin-emu.org/download/dev/a9a8c730748b8c8a2e83feb4c38626361cf9daa1/
PR 68: https://github.com/dolphin-emu/dolphin/pull/68

#2 Updated by JMC4789 about 4 years ago

Please provide a 3 frame fifolog of the issue.

https://wiki.dolphin-emu.org/index.php?title=Fifoplayer

#3 Updated by marvinl97 about 4 years ago

There you go. I hope I did it right.

My system is the second one listed above. I also updated my driver to 15.12 today.

#4 Updated by JMC4789 about 4 years ago

Looks like a fifolog won't help us here :(

I tried playing the recording back, and I don't see a difference in the playback between 4.0 and master. Sorry for wasting your time on that.

Looks like I need to find the game if I want to reproduce this.

#5 Updated by JMC4789 about 4 years ago

Shot in the dark: Try toggling fast-depth to see if that affects it.

#6 Updated by marvinl97 about 4 years ago

It doesn't effect it. But if I turn on any 3D mode, the water is correct and fish are visible.

#7 Updated by SirBanjo about 4 years ago

seems like a AMD specific problem. I tried it again on my notebook with Nvidia geforce GT 540M and it looks fine.

#8 Updated by seapancake about 4 years ago

5124
5125
5126

Works fine in D3D on GTX970 in 4.0-4800 at 1x (RUUP01-1.png and RUUP01-2.png) and 8x AF (RUUP01-4.png) although loading my save in OGL fills the screen with ocean so not sure what's going on there.

#9 Updated by marvinl97 over 3 years ago

I want to note that the water is fixed using Direct3D 12. The remaining render backends are still broken for me in 5.0-369.

#10 Updated by EblfIYH almost 3 years ago

I tried this game using both D3D and OGL, none of them had this problem, tested on 5.0-2849, i think this was solved some versions ago though

#11 Updated by EblfIYH almost 3 years ago

Tested again in 5.0, the bug was not present

#12 Updated by seapancake almost 3 years ago

Tested in 5.0-2877 and working with OpenGL and D3D 11 (Didn't test 12) looks like it's fixed?

#13 Updated by JMC4789 over 2 years ago

  • Status changed from New to Fixed

Reported as fixed.

Also available in: Atom PDF