Project

General

Profile

Emulator Issues #9188

Enabled Speaker Data Still causes Balance Board to Disconnect

Added by JMC4789 about 3 years ago. Updated 9 months ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Wii Fit Plus - RFPE01

What's the problem? Describe what went wrong.

When doing the step-counter games (Free Step) that use the Wiimote audio for timings, the Balance Board has a high probability of disconnecting regardless of bluetooth stack. The only work-around for this is to disable Wiimote Speaker data, but then you can't hear the sounds to do the pattern.

What steps will reproduce the problem?

You have to start the game, have a balance board, go through all the stuff to get to the main game (body test and whatnot) and then you can finally select games. In one of the work-outs, there are step minigames (they're all unlocked at the start.) You can just select free-step, and it'll disconnect within 20 steps usually.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

No versions helped. Verified in 4.0-8400

What are your PC specifications? (CPU, GPU, Operating System, more)

Core i5 3570K, GTX 760, Windows 7

History

#1 Updated by rancourttommylee about 3 years ago

what is your usb bluetooth me i have a usb bluetooth version:4.0 3mbps

#2 Updated by leoetlino over 2 years ago

I tried to reproduce this, but I failed to. It works with:

  • Linux, official -TR Wiimote (DolphinBar), Balance Board (DolphinBar)
  • Linux, official -TR Wiimote (DolphinBar), Balance Board (bluez) -- note: audio doesn't work at all with bluez for some reason
  • Linux, non -TR Wiimote (DolphinBar), Balance Board (DolphinBar)
  • Linux, non -TR Wiimote (bluez), Balance Board (bluez)
  • Linux, third-party -TR Wiimote (DolphinBar), Balance Board (DolphinBar)
  • Linux, third-party -TR Wiimote (bluez), Balance Board (bluez)

(I can't test this on Windows, since I only have a VM, and the only renderer that works in it is Null… Let's say it's a bit complicated to navigate the menus with the Null video backend.)

I stopped and didn't test more combinations because the game was finished, and I reached 933 steps.

#3 Updated by JMC4789 9 months ago

  • Status changed from New to Won't fix

It's probably a Windows issue and honestly with Bluetooth Passthrough and Linux I don't know it's worth caring.

Also available in: Atom PDF