Project

General

Profile

Emulator Issues #924

Dolphin x64 linker broken

Added by hondza555 over 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Build dolphin with visual studio 2008
2.
3.

What is the expected output? What do you see instead?
HLE build
1>audiocommon.lib(DSoundStream.obj) : error LNK2019: unresolved external
symbol DirectSoundCreate8 referenced in function "public: virtual bool
__cdecl DSound::Start(void)" (?Start@DSound@@UEAA_NXZ)

Padsimple build
2>inputcommon.lib(DirectInputBase.obj) : error LNK2001: unresolved external
symbol c_dfDIKeyboard
2>inputcommon.lib(DirectInputBase.obj) : error LNK2001: unresolved external
symbol GUID_SysKeyboard
2>inputcommon.lib(DirectInputBase.obj) : error LNK2019: unresolved external
symbol DirectInput8Create referenced in function "public: long cdecl
DInput::Init(struct HWND
*)" (?Init@DInput@@QEAAJPEAUHWND__@@@Z)
2>inputcommon.lib(DirectInputBase.obj) : error LNK2001: unresolved external
symbol IID_IDirectInput8A

LLE build
5>audiocommon.lib(DSoundStream.obj) : error LNK2001: unresolved external
symbol DirectSoundCreate8

nJoy build
3>Rumble.obj : error LNK2001: unresolved external symbol c_dfDIJoystick
3>Rumble.obj : error LNK2001: unresolved external symbol DirectInput8Create
3>Rumble.obj : error LNK2001: unresolved external symbol GUID_ConstantForce
3>Rumble.obj : error LNK2001: unresolved external symbol IID_IDirectInput8A

What version of the product are you using? On what operating system?
Visual studio 2008 / windows xp

Please provide any additional information below.
none

History

#1 Updated by death2droid over 10 years ago

:P i don't have that problem.
Make sure you have the direct x sdk installed!

#2 Updated by hondza555 over 10 years ago

Sure. I install latest direct sdk and set x64 all path.

#3 Updated by lpfaint99 over 10 years ago

  • Status changed from New to Invalid

it really looks like directx isnt installed correctly. x64 links fine here

#4 Updated by hondza555 over 10 years ago

Opp! Sorry i set wrong path.

Also available in: Atom PDF