Project

General

Profile

Emulator Issues #9280

Put a message in the TAS system when official DSP files are used.

Added by Sonicadvance1 about 5 years ago. Updated about 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

The TAS Movie code saves a copy of the DSP files inside of the movie file.
I presume this is due to issues arising when recording with official files and playing back with Dolphin's unofficial ones.
Potentially an issue raised when sharing these files to a TAS website for verification purposes and they couldn't verify properly due to DSP files mismatching and causing desyncs? No sure there.
In any case, throw up a message when using the official Nintendo files that distributing the movie file is illegal and you shouldn't do it.

History

#1 Updated by JosJuice about 5 years ago

I wasn't aware that we stored anything about the DSP files other than two hashes. Can you show what part of DTMs they're saved in, or where Dolphin's code for saving them is?

#2 Updated by Sonicadvance1 about 5 years ago

  • Status changed from New to Invalid

Oh you're right. I didn't look close enough, it is only doing a hash.
derp derp derp.

Also available in: Atom PDF