Project

General

Profile

Emulator Issues #9304

The latest NVIDIA drivers generate random black frames in OpenGL mode (NVidia 820M)

Added by intruso almost 5 years ago. Updated almost 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Weeks ago I noticed various games showed black frames randomly with OpenGL using the Nvidia CPU. The game (of my collection) most affected by this bug is Mario Golf (pal?).
Almost any game I tested suffer this problem (in some of them it's so uncommon that it's almost unnoticeable). Disabling the framerate limiter makes it worse. Lowering the framerate (50Hz PAL games) reduces or removes it.

TOday I tried to install an older version of the drivers and the bug dissapear.
It looks like the version 361.43 and higher causes this.

Any version of Dolphin are affected. Direct3D and OpenGL using my Intel GPU remains unaffected.

I'm sure this is a bug of NVidia and not of Dolphin, but I think the devs will want to investigate this.

SPECS (Laptop)
i5 4210M (2.6GHz) CPU, Geforce 820M GPU and Intel HD 4600, 4GB RAM, Windows 10 x64

History

#1 Updated by intruso almost 5 years ago

...currently I'm using 359.06-notebook-win10-64bit-international-whql drivers. They work fine.

With the broken drivers, I can avoid the bug if I use RealXFB.

#2 Updated by intruso almost 5 years ago

Fixed after the latest Nvidia update.

#3 Updated by JosJuice almost 5 years ago

  • Status changed from New to Invalid

Marking as invalid since this apparently isn't a Dolphin bug.

Also available in: Atom PDF