Project

General

Profile

Emulator Issues #9319

Metal Gear Solid, glitched with Dual Core ON

Added by eckso almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

MGS: The Twin Snakes

Game ID? (right click the game in the game list, properties, info tab)

GGSPA4

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

The radio communication panel is glitched in that it doesn't show text

What steps will reproduce the problem?

Start the game and reach where snake and boss communicates on radio.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

latest

What are your PC specifications? (CPU, GPU, Operating System, more)

4670K, 750 Ti, Win7 SP1 x64


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by eckso almost 4 years ago

Forgot the hash, it's: 4D44FC6DA6D2FBC7A47E7FDDA868139C

#2 Updated by JosJuice almost 4 years ago

  • Status changed from New to Duplicate

#3 Updated by JosJuice almost 4 years ago

#4 Updated by eckso almost 4 years ago

#7143: What a shameful and discouraging bug report that is, adding games to that is an oxymoron, just list every single game in their various region flavors, as before or after all of them are going to break.

I will open a new PR (problem report :P ) for Dual Core issues on 1080º Avalanche, feel free to merge that too.

#5 Updated by JosJuice almost 4 years ago

What's so shameful about collecting information about a single issue in one place instead of leaving it scattered across lots of different reports? And no, not all games break with dual core.

#6 Updated by eckso almost 4 years ago

A minute ago you didn't know 1080º had issues and now you tell me "not all games break with dual core".

What is shameful is what I just said; collect all broken games and do nothing about it (not even report on the Wiki), that's extremely shameful if you ask me.

#7 Updated by JosJuice almost 4 years ago

Yes, there are games that break with dual core that we aren't aware about. That doesn't mean all games break with dual core. There are games that have been well tested without any problems.

Reporting it on the wiki is a solution I agree with. (In issue 9317, JMC wrote about why we can't really solve it in Dolphin.) However, the issue tracker isn't the place for talking about that. Anything regarding the wiki is done on the wiki. As far as I know, the only reason the wiki lacks information about this for some games is because nobody has tested it or written about it. This is where you can help – you can edit the wiki pages for the games with dual core instabilities that you found.

#8 Updated by MayImilae almost 4 years ago

eckso said:

What is shameful is what I just said; collect all broken games and do nothing about it (not even report on the Wiki), that's extremely shameful if you ask me.

There are games that require icache emulation to work, but icache emulation would increase the demands of the emulator by 20 to 30 times! There's more. The graphics backends will never be 100% accurate! Going to a pure software mode would increase the demands of Dolphin even more! JITs have limitations too. There's a reason Byuu went with pure software for Higan! Raising internal resolution is a serious hack, and causes graphics problems, should that go too? EFB to Texture is much worse than dual core, yet it is on by default too!

Dolphin needs contributors and users to grow, so the developers have to balance features, performance, and accuracy, otherwise the emulator will die. So no, it is not "shameful". It is part of developing an emulator before the power to completely accurately emulate it exists.

You need to respect the decisions of the developers in balancing a huge amount of factors you have no knowledge of.

#9 Updated by eckso almost 4 years ago

"There are games that have been well tested without any problems"
Where can I read about this?

"JMC wrote about why we can't really solve it in Dolphin"
I never promoted a fix for Dual Core, just a change in defaults, or report on Wiki.

"Anything regarding the wiki is done on the wiki"
Then my misunderstanding. I thought anything related to Dolphin was reported here.
I never touch Wiki, as it's a VERY volatile environment I'm not leaned to invest my time on.
Out of curiosity, do all games listed on #7143 (except last two of mine) have a Dual Core note on Wiki?

#10 Updated by eckso almost 4 years ago

@MaJoRoesch, as I said #9137 wasn't about technical issues (solving Dual Core), but political. That's why I don't agree on the duplicate tag that it was assigned to. My claim was to DO SOMETHING ABOUT IT, not "fix it".

Ideas to "DO SOMETHING ABOUT IT" from IMHO best to worst options: Turn off Dual Core, turn off Dual Core on games INI* (as per #7143), report on Wiki.
Currently there's a state of inaction, contemplative stance that is no-good to further issue reports and user feedback.

*"EFB to Texture is much worse than dual core, yet it is on by default too!" Yes, but unlike Dual Core it was handled on the games ini, becoming transparent to the end user.

Also available in: Atom PDF