Project

General

Profile

Emulator Issues #9375

Super smash bros melee broken audio

Added by Guitarkory1 almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Super Smash bros melee]

Game ID? (right click the game in the game list, properties, info tab)
GALE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)
0e63d4223b01d9aba596259dc155a174

What's the problem? Describe what went wrong.
Sometimes when playing a level, the music will stop playing but the sound effects will continue to play normally.

What steps will reproduce the problem?

I was playing in classic mode at the time, happens randomly during levels, and when matches finish.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

dolphin 4.0-version 8987

What are your PC specifications? (CPU, GPU, Operating System, more)
Lenovo y70 touch
intel i7- 4020hq @ 2.6 (turbo to 3.6)
Nvidia 960m 4gb

**Is there any other relevant information?

I think it is more common when the shaders are compiling (especially during the beginning of a level), the audio just stops after its finished.

properties.png (25.8 KB) properties.png Guitarkory1, 02/25/2016 08:37 PM
setting 1.png (19 KB) setting 1.png Guitarkory1, 02/26/2016 04:49 PM
setting 2.png (17.1 KB) setting 2.png Guitarkory1, 02/26/2016 04:49 PM
setting 3.png (17.7 KB) setting 3.png Guitarkory1, 02/26/2016 04:49 PM
setting 4.png (25.1 KB) setting 4.png Guitarkory1, 02/26/2016 04:49 PM
setting 5.png (21.7 KB) setting 5.png Guitarkory1, 02/26/2016 04:49 PM
5286
5287
5288
5289
5290
5291

Related issues

Is duplicate of Emulator - Emulator Issues #9360: Disc load speeds no longer accurate after 4.0-8919Fixed

History

#1 Updated by JMC4789 almost 3 years ago

right click the game in the gamelist and show a screenshot of the game properties page.

#2 Updated by Guitarkory1 almost 3 years ago

5286

here is the properties. I hope I did this right!

#3 Updated by Guitarkory1 almost 3 years ago

if it helps I have realtek hd audio on my laptop. It also happens when I use my headphones to, not just my speakers.

#4 Updated by Guitarkory1 almost 3 years ago

Guitarkory1 wrote:

if it helps I have realtek hd audio on my laptop. It also happens when I use my headphones to, not just my speakers.

Oh yeah, and I have HLE audio enabled, havent tried lle

#5 Updated by oOSuperMarioOo almost 3 years ago

The music stopping midway also happened to me in Super Smash Bros. Melee but on my Nvidia Shield Android TV. However, the audio issue only happens when I turn on Speed Up Disc Transfer Rate (also known as "Fast Disc Speed" in Dolphin.ini); if it's turned off, the music won't have any problems during gameplay.

#6 Updated by Guitarkory1 almost 3 years ago

I tried what you said and turned it off, (it was never really on in the first place. it happens without fail on the snag the trophy stage (special stage 2) for classic mode no matter what character I use. all i hear is the sound effects of my character until the stage is complete, then the music plays again. The start of the stage can play music for about 2 or 3 seconds and then stops.

#7 Updated by JMC4789 almost 3 years ago

I feel like some setting is totally messed up in some way. Melee is rock solid for me and a community of tons of people. I don't know what you have wrong, but I know something, somewhere is.

#8 Updated by Guitarkory1 almost 3 years ago

You know what, I was using custom textures from the forums( a really old texture pack), and when I turned them off the stuttering stopped and the music works normally

#9 Updated by Guitarkory1 almost 3 years ago

its really weird because I can use texture packs fine for all of my games and the games run normally with no music loss, and no stuttering (besides xenoblade/tls, but thats caused by shader compilation)

#10 Updated by Guitarkory1 almost 3 years ago

actually just tested some more and it still loses audio sometimes, ill post some more of my settings.

#12 Updated by Guitarkory1 almost 3 years ago

This doesn't happen on ishiiruka(or for that matter, the older stable dolphin 4.0, so for now I guess I will have to use it.

#13 Updated by JMC4789 almost 3 years ago

No, that's not how it works. We need to find out what's causing it. Can you try latest master? There was a slight disc timing change between a few builds you mentioned.

#14 Updated by Guitarkory1 almost 3 years ago

I update my dolphin emu every day, I will try the version before the change and see if that one works

#15 Updated by Guitarkory1 almost 3 years ago

I'm sorry, I forgot to update this morning, version 9012 wasn't working, but version 9019 is. I went through a playthrough and everything is working perfectly (ill continue to test). maybe I could put a feature request in for a dolphin update check button on the emulator.

#16 Updated by Guitarkory1 almost 3 years ago

Thanks for all your help JMC! You guys have my respect! I can only hope I'm as good as you guys with programming when I'm finished with college!

#17 Updated by JosJuice almost 3 years ago

  • Status changed from New to Duplicate
  • Regression changed from No to Yes

Then this was likely fixed by 4.0-9019.

#18 Updated by JosJuice almost 3 years ago

Also available in: Atom PDF