Project

General

Profile

Emulator Issues #9384

Final Fantasy Crystal Chronicles Menu Error

Added by gmariani405 over 3 years ago. Updated 8 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Final Fantasy Crystal Chronicles

Game ID? (right click the game in the game list, properties, info tab)

GCCE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

a6d6064396b20c0d0d836afad97d3a4c

What's the problem? Describe what went wrong.

Error codes displaying after menu closed within game:

Invalid read from 0x3edc688c, PC = 0x8001e054
Invalid read from 0x3edc688e, PC = 0x8001dfdc
Invalid read from 0x3edc6892, PC = 0x8001dfdc
Invalid read from 0x3edc689a, PC = 0x8001e010
Invalid read from 0x3edc688c, PC = 0x8001e038
Invalid read from 0x3edc689a, PC = 0x8001e054
Invalid read from 0x3edc6892, PC = 0x8001e054

What steps will reproduce the problem?

Playing the game, and visited Alfitaria and after the menu closed (from talking to townsfolk or editing character) the following 7 prompts would display:

Invalid read from 0x3edc688c, PC = 0x8001e054
Invalid read from 0x3edc688e, PC = 0x8001dfdc
Invalid read from 0x3edc6892, PC = 0x8001dfdc
Invalid read from 0x3edc689a, PC = 0x8001e010
Invalid read from 0x3edc688c, PC = 0x8001e038
Invalid read from 0x3edc689a, PC = 0x8001e054
Invalid read from 0x3edc6892, PC = 0x8001e054

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 4.0-9021 as of today
Was using 4.0-8945 for the past couple of days without this issue. But I also wasn't using VBA-M at the time.
Tested with 9023 and issue occurs as well

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i7 4790K
Nvidia GeForce GTX 960
Windows 10 x64
32gb DDR3

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

was playing with the following configuration:
Dolphin in windowed mode, Wii Gamecube Adapter set as controller 1, and GBA as controller 2.
VBA-M open on the side and connected as controller 2
Gamecube Wavebird connected to Wii Gamecube Adapter

Just tested 4.0-9021 without VBA-M from a save state and issue still occurs.

2016-02-28_20-08-26.mp4 (4.31 MB) 2016-02-28_20-08-26.mp4 gmariani405, 02/29/2016 01:09 AM

Related issues

Has duplicate Emulator - Emulator Issues #9644: Invalid read from 0x3edc6892, PC = 0x8001dfdcDuplicate

Is duplicate of Emulator - Emulator Issues #9915: Final Fantasy Crystal Chronicles (Goblin Wall - Mogmail) Read/write errorAccepted

History

#2 Updated by JMC4789 over 3 years ago

Does the game itself crash afterwards? Can you bisect and find a build that works? Or has this happened forever?

#3 Updated by gmariani405 over 3 years ago

If you watch the video I made, it doesn't crash afterwards. It also still messed up with 8945 (i reverted later to test). BUT I noticed that when I go back into the first zone you start in, i don't get the error message anymore. I'll have to do more testing to see exactly where it errors out.

It didn't start until I got into the second zone but that was at the same time i upgraded Dolphin so I didn't think that could be the cause at the time. I think otherwise now but need to test.

#4 Updated by JMC4789 over 3 years ago

Please keep me updated. I'm absolutely willing to accept this as an urgent issue if it's a regression.

#5 Updated by kungfupika over 3 years ago

Did anyone every figure this out? I'm playing right now and It's giving me the same menu issue in Alfitaria...

#6 Updated by JMC4789 about 3 years ago

#7 Updated by JMC4789 about 3 years ago

This still happens in 5.0 according to another issue report. We'll need to look into this eventually.

#8 Updated by baciobacio about 3 years ago

JMC4789 wrote:

This still happens in 5.0 according to another issue report. We'll need to look into this eventually.

Hi! Wanted to add to this report that myself and my roommate are playing this game currently and both have the same issue.

#9 Updated by letit_rainthen almost 3 years ago

baciobacio wrote:

JMC4789 wrote:

This still happens in 5.0 according to another issue report. We'll need to look into this eventually.

Hi! Wanted to add to this report that myself and my roommate are playing this game currently and both have the same issue.

I am also having the exact same issue, has this not been resolved yet?

#10 Updated by MoonAtsu over 2 years ago

I am also playing in 5.0 and have discovered something unfortunate. After the errors started I fugred I would save my character and reload to get rid of it only to find my character gone. It happened again cause I didn't know it was a thing and found out that my character did save, but you have to get it into the glitch state before it will show them. Do NOT go to Alfitaria.

#11 Updated by kyerstopus about 2 years ago

MoonAtsu wrote:

I am also playing in 5.0 and have discovered something unfortunate. After the errors started I fugred I would save my character and reload to get rid of it only to find my character gone. It happened again cause I didn't know it was a thing and found out that my character did save, but you have to get it into the glitch state before it will show them. Do NOT go to Alfitaria.

The same thing happened to me.

#12 Updated by Stynker over 1 year ago

I have another prompts display trying to closing the shop menu:

Invalid read from 0x3e2e1bed, PC = 0x8001e260

has this not been resolved yet?

:(

#13 Updated by JMC4789 8 months ago

  • Status changed from New to Duplicate

Same issue at 9915. Confirmed

#14 Updated by JMC4789 8 months ago

  • Is duplicate of Emulator Issues #9915: Final Fantasy Crystal Chronicles (Goblin Wall - Mogmail) Read/write error added

Also available in: Atom PDF