Project

General

Profile

Emulator Issues #9405

Many areas are unplayable

Added by SoaringHawk820 almost 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand Year Door

Game ID? (right click the game in the game list, properties, info tab)

G8ME01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

db9a997a617ee03bbc32336d6945ec02

What's the problem? Describe what went wrong.

At many points, events fail to actually happen and the game essentially freezes. Some examples of what isn't working include Professor Frankly's Gate not opening, the warp pipe to Hooktail's Castle not appearing, the secret entrance to the Great Tree in Chapter 2 not showing up, and the Jackie's hives not being destroyed.

What steps will reproduce the problem?

Go to any of these spots in the game and try to progress to the next section of the game

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0 - 9081

What are your PC specifications? (CPU, GPU, Operating System, more)

Mac OS X 10.11.3
2.8 GHz Intel Core i7
Intel Iris Pro 1536 MB
16 GB RAM

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]


Related issues

Is duplicate of Emulator - Emulator Issues #8931: Bounding box emulation only works when SSBO is supportedFixed

History

#1 Updated by Sonicadvance1 almost 5 years ago

  • Status changed from New to Working as intended

This is due to OSX only supporting GL 4.1 and the feature required to emulate the bounding box feature that these games require in order to run requires GL 4.2 or ES 3.1.

#2 Updated by degasus almost 5 years ago

https://wiki.dolphin-emu.org/index.php?title=Paper_Mario:_The_Thousand-Year_Door#Professor_Frankly.27s_Gate

@Sonic: Nope, OSX support 4.2, but we require 4.3 for bounding box emulation.

Feel free to use bootcamp to try dolphin in windows. It should be both faster (because of a bit better GL and much better D3D driver) and more stable (on windows, the OGL driver supports 4.3)

#3 Updated by JosJuice almost 4 years ago

#4 Updated by JosJuice almost 4 years ago

  • Status changed from Working as intended to Duplicate

Also available in: Atom PDF