Project

General

Profile

Emulator Issues #9460

[BBox not working recent builds)]

Added by brujo55 over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[paper mario the thousand year door]

Game ID? (right click the game in the game list, properties, info tab)

[G8MP01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[e327350d100f9dac66ad3c61957b7e45]

What's the problem? Describe what went wrong.

[Professor Frankly will stand in front of his gate not moving. BBox True/False do nothing
this problem hapend on windows and android]

What steps will reproduce the problem?

[you just have to play until Professor Frankly's Gate at the begining]

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[the last time it worked was in 4.0 early builds, so no t working for me in any recent builds]

What are your PC specifications? (CPU, GPU, Operating System, more)

[interl core i3 @ 2.8ghz, Intel HD 4000, windows 8 64bits, ES 3.1
samsung galaxy s6, mali gpu, android 5.1.1]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[tested using Direct3D 11 backend, OpenGL is very slow for me.
in android thansfered my gamesettings folder from pc version but still the same as windows]

thumb.png (203 KB) thumb.png stuck here brujo55, 03/28/2016 05:46 PM
5345

Related issues

Is duplicate of Emulator - Emulator Issues #8931: Bounding box emulation only works when SSBO is supportedQuestionable

History

#1 Updated by JMC4789 over 6 years ago

Your Intel HD4000 does not support hardware bounding box.

#2 Updated by JosJuice over 6 years ago

  • Status changed from New to Duplicate

#3 Updated by JosJuice over 6 years ago

#4 Updated by brujo55 over 6 years ago

JMC4789 wrote:

Your Intel HD4000 does not support hardware bounding box.

What happens with android nvidia X1 and Mali t760 ES3.1 +aep?

Thanks

#5 Updated by degasus over 6 years ago

It works fine on the X1. But you mali driver just does not support it. Bad luck, the hardware would be able to...

But the HD4000 should be able to do so. Just try the D3D11 backend.

#6 Updated by brujo55 over 6 years ago

wickmarkus86 wrote:

It works fine on the X1. But you mali driver just does not support it. Bad luck, the hardware would be able to...

But the HD4000 should be able to do so. Just try the D3D11 backend.

Thanks for your response.

#7 Updated by brujo55 over 6 years ago

JMC4789 wrote:

Your Intel HD4000 does not support hardware bounding box.

are you sure?

sonicadvance1 says:

ES 4.3 isn't a real thing.
With desktop GL it requires GL 4.3.
With ES it only requires ES 3.1.

so my galaxy s6 can emulate bbox but it does not work

#8 Updated by Helios over 6 years ago

Can you rule out that your mobile drivers correctly expose and implement the extensions required for bounding box? Mali may have a broken 3.1 driver.

#9 Updated by Helios over 6 years ago

  • Status changed from Duplicate to Invalid

The SGS6 has a Mali driver that only supports ES 3.0 in 5.1.1, Android 6.0 is when the SGS6 gets ES 3.1. There is nothing we can do about this.

#10 Updated by Helios over 6 years ago

  • Status changed from Invalid to Duplicate

I'm dumb.

Also available in: Atom PDF