Project

General

Profile

Emulator Issues #9483

Netflix Wiiware app crashes/hangs the emulator

Added by waddlesplash almost 4 years ago. Updated almost 3 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-2127

Description

Game Name?

Netflix

Game ID? (right click the game in the game list, properties, info tab)

HCLEXN

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

e75774a94106cb2242e765c95a08443d

What's the problem? Describe what went wrong.

Title doesn't work. On JIT64, the following message box appears shortly after launching it:

---------------------------
Warning
---------------------------
BackPatch - failed to disassemble MOV instruction

Error encountered accessing emulated address 82000000.
Culprit instruction: 
movaps dqword ptr ds:[rbx+rax], xmm0
at 0x1bc21b5d
---------------------------
OK   
---------------------------

Dolphin crashes as soon as "OK" is pressed.

On (Cached) Interpreter and JITIL, after a long period of time of nothing happening, the following message box appears:

---------------------------
Warning
---------------------------
IntCPU: Unknown instruction 00000000 at PC = 00000300  last_PC = 00000000  LR = 803c4998
---------------------------
Yes   No   
---------------------------

An infinite stream of message boxes follow, each time with the PC incrementing. As soon as "No" is pressed, the emulator crashes.

What steps will reproduce the problem?

Start the game.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-9177, but it's happened for as long as I can recall.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel i3-5005U CPU, Intel HD Graphics 5500, Windows 10, 8GB RAM.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

All default settings in Dolphin, never initializes graphics output so no screenshots.

History

#1 Updated by Lumbeeslayer almost 4 years ago

Its pointless threads like this that pisses me off. Why the hell would you be trying to watch Netflix using dolphin, that's beyond pointless.

#2 Updated by JosJuice almost 4 years ago

That's a valid reason to deprioritize fixing the issue, but it's a valid issue that can be reported nonetheless. I would rather say that your comment is what is pointless. Unimportant issue reports (which this one isn't necessarily) will die off on their own without having to complain about them.

#3 Updated by phire almost 4 years ago

  • Status changed from New to Accepted
  • Priority changed from Normal to Low

#4 Updated by PEmu almost 3 years ago

#5 Updated by JosJuice almost 3 years ago

  • Status changed from Accepted to Fixed
  • Fixed in set to 5.0-2127

Also available in: Atom PDF