Project

General

Profile

Emulator Issues #9486

Random inputs with official WiiU Adaptor on games

Added by TehBazzard about 5 years ago. Updated over 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Super Smash Bros. Melee

Game ID? (right click the game in the game list, properties, info tab)

GALE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

0e63d4223b01d9aba596259dc155a174

What's the problem? Describe what went wrong.

When using the GC WiiU Adaptor released by Nintendo, the game seems to make random inputs, usually to the down and left position on both the C-Stick and Directional Stick. Occasionally, it'll even stick in that position. Sometimes unplugging and replugging the controller fixes it, but if it does, it's only temporary. When I removed the entire adaptor from my PC, it seems that the input was being made still even with the adaptor removed, and I could then confirm it was making the input on all four controller slots.

I want to stress that this doesn't just occur on SSBM: it happens far more frequently on Wii games. I've tested this on Super Smash Bros. Brawl and also the mod for that game, Project M, booted up via Gecko. It seems to be an emulator-wide issue.

What steps will reproduce the problem?
Just playing Smash Bros. will incur the issue.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?
4.0 9103, and then in 4.0 9211. In 9211, I had the odd curiosity of the emulator then not taking ANY inputs except for the down-right input.

What are your PC specifications? (CPU, GPU, Operating System, more)

Operating System: Windows 10 Home 64-bit (10.0, Build 10586) (10586.th2_release_sec.160223-1728)
Processor: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G (4 CPUs), ~2.5GHz
Memory: 8192MB RAM

Card name: AMD Radeon(TM) R6 Graphics
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon Graphics Processor (0x130D)
DAC type: Internal DAC(400MHz)
Device Type: Full Device
Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

The controller I am using is the Smash 4 Reprint GC controller. I went ahead and tried with an original run GC controller and a Wavebird. No issue. Also no issue with a 360 pad on my end and the proper settings.

Again, I know Project M is a mod and it occurs worse on there, but the problem also existed with Melee and Brawl.

Power4Gear_Hybrid.png (204 KB) Power4Gear_Hybrid.png bueno, 11/11/2019 07:24 PM
7614

Related issues

Has duplicate Emulator - Emulator Issues #9730: [Netplay] Official GCN Controller adapter random down-left inputs on control and C stickDuplicate

Has duplicate Emulator - Emulator Issues #10673: Mayflash gamecube adapter random inputs [Can't play]Duplicate

History

#1 Updated by JMC4789 about 5 years ago

Usually when something like this happens, it's due to another program (usually a sound driver?) stealing the adapter because they use LibUSB.

I don't think this is Dolphin's bug. Please turn on logging and see if the adapter is being disconnected while you play.

#2 Updated by DrHouse64 about 5 years ago

Actually I think it's a Dolphin bug. It also happens to me. I never had this problem before.
See : https://forums.dolphin-emu.org/Thread-wiiu-gc-adaptater-is-slightly-broken

#3 Updated by JMC4789 about 5 years ago

I played a 6+ hour marathon on netplay earlier tonight with an official GC adapter and did not run into a bug.

Unless someone can get more information, there's nothing that can be done unless a developer runs into the bug.

If a random direction is hitting, 99% of the time it means we lost connection to the adapter. If you turn on log messages, you should see the adapter getting disconnected when this bug occurs. This should give us the necessary information on how to move forward.

Thank you for your time.

#4 Updated by TehBazzard almost 5 years ago

Turned on the logs and the issue occured. It was just as you expected. The adaptor is reading as detaching and reattaching. I just don't know why it does this. My cables were rested on a table so they didn't drop, and the device works just fine on my WiiU. Pastebin logs are included below.
http://pastebin.com/Mem5cE6Z

#5 Updated by mathieui almost 5 years ago

Thanks for the log, it does look like windows drivers madness again. You could try removing other usb devices (such as mouse or keyboard). See https://bugs.dolphin-emu.org/issues/8552 (it was considered fixed because they weren’t using the adapter at that time, so disabling the adapter entirely fixed it), but there’s not much we can do about it, if it is this issue.

I’ll submit a libusb update to dolphin externals in the next few days, but I don't have too much hope…

#6 Updated by PEmu over 4 years ago

mathieui wrote:

Thanks for the log, it does look like windows drivers madness again. You could try removing other usb devices (such as mouse or keyboard). See https://bugs.dolphin-emu.org/issues/8552 (it was considered fixed because they weren’t using the adapter at that time, so disabling the adapter entirely fixed it), but there’s not much we can do about it, if it is this issue.

I’ll submit a libusb update to dolphin externals in the next few days, but I don't have too much hope…

Are you still planning on updating libusb? There have been a number of complaints about random input using GameCube controllers since this report was made and it would be nice to see if updating it helps at all.

#7 Updated by JosJuice over 4 years ago

  • Has duplicate Emulator Issues #9730: [Netplay] Official GCN Controller adapter random down-left inputs on control and C stick added

#8 Updated by Nightfirecat over 4 years ago

I'm experiencing this same issue on 5.0-321 (specifically while playing 0e63d4223b01d9aba596259dc155a174) with one caveat regarding when/how it is being caused: I'm only seeing the adapter disconnection while moving my mouse; otherwise, it remains connected without any issues.

#9 Updated by PEmu over 4 years ago

libusb has now been updated to 1.0.20. Could a user who has had issues with random inputs with the Wii U adapter test with the latest Dolphin development builds to see if there is any improvement?

#10 Updated by leoetlino over 4 years ago

And now libusb has been updated to 1.0.21. I doubt that will fix any issues on master though, but there's another thing you can try.

1.0.21 introduces a new libusb backend on Windows (usbdk). Since it's an entirely new backend, it may not have this problem at all. For instructions on how to try it, see this post: https://www.reddit.com/r/emulation/comments/5k8ho4/looking_for_feedback_potentially_changing_usb/dbm3eyy/

You can ignore things that are specific to USB passthrough (whitelisting devices); all you need to do is use the special PR build, launch Dolphin and use your GC adapter as usual.

#11 Updated by FourSword almost 4 years ago

I've recently been having this problem so I figured I'd contribute to doing some testing and try to uncover the reason behind this issue.
A bit of background history:

  • I've been aware of this issue for some time but have never experienced this problem for myself in the last 12-24 months of using the dolphin emulator
  • Recently I've started streaming and ever since that time I've been having this issue.

Things I've tried to resolve the issue on my own:
- Plugging different controllers in the GC adapter (did not help)
- Reinstall zadig several times (did not help, except for one instance)
- Using different USB ports (did not help)
- Use different versions of dolphin (did not help)
- Disconnecting all other USB devices (did not help)

Some users on IRC suggested I tried the logger within dolphin, as other users have found:
The adapter seems to disconnect and reconnect at several intervals (can provide the logs if necessary)

After talking to JMC47 I've decided to do a quick test of the following:
- Try to minimize the amount of open processes/applications, at first I decided to kill OBS completely.
1. After OBS was killed I started up netplay and tested it with another user; the random inputs did not occur.
2. Immediately after I started OBS back up again and started streaming; the random inputs started occurring again.
I was utilizing a Window Capture method for capturing dolphin gameplay.

I'm available for further testing if necessary, hopefully these results will help further identify the cause/problem.

#12 Updated by leoetlino over 3 years ago

  • Status changed from New to Invalid
  • Operating system Windows added
  • Operating system deleted (N/A)

This sounds like something that Dolphin can't fix, unfortunately.

#13 Updated by FourSword over 3 years ago

Hey leoetlino,

It does seem like that is the case since most of the information I've found talks about libusb losing focus due to some reason.
So expecting a solution out of dolphin might not be realistic.

With that said in older versions of dolphin (think 4.0 development versions) this problem was not nearly as aggravating.
The difference is in that since 5.0 and up this issue will input a down/left input (and sometimes A) which causes weird behavior in games, while in 4.0 the input would simply reset to neutral (with no input of A).

Obviously both are not ideal, but I'm wondering if it's possible to make it behave more or less the same way as in 4.0.

#14 Updated by thisproblemisstillhere over 3 years ago

Has anyone figured this out?

#15 Updated by leoetlino over 3 years ago

#16 Updated by kdizzle340 about 3 years ago

I'm still having this problem and it SUCKS. nothing i do seems to fix this. I don't even know why the USB port would behave like this. My PC and adapter should both be behaving fine, but instead I get these constant down and left inputs as my adapter fails with Dolphin. :angery:

#17 Updated by ItsZev over 2 years ago

Switched from a USB 3.0 to a USB 2.0 and it fixed the issue.

#18 Updated by bueno over 1 year ago

7614

I finally found a different fix for this bug. But first, here is a bit of background history.

I played several months with the GC adapter, without having encountered this bug. Then suddenly, after 2 weeks without launching Dolphin, this bug occurs, sending down + left inputs almost every 30 seconds on every game.

I tried all fixes describe above, but none of them work for me. During one month, the bug occurs on every play. Then one week ago, I found that the problem came from my computer, not Dolphin.

My computer is running an ASUS software called "Power4Gear Hybrid", which offer 4 ways to manage the power settings of the computer: "High Performance", "Entertainment", "Quiet Office" and "Battery Saving" (see attached screenshot). Due to a stupid keyboard shortcut, the selected mode switched from "High Performance" to Entertainment".

I switched it back to "High Performance", and since then the random input bug is gone :o

If you still have this bug, please look if your computer is not running on a "slow" mode like mine ;)

Also available in: Atom PDF