Project

General

Profile

Emulator Issues #9487

Internet Channel - Keyboard glitching at non-integer internal resolutions (Direct3D 11)

Added by gflas about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Internet Channel

Game ID? (right click the game in the game list, properties, info tab)

HADP01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

23dcef3d269add05f357f827c5aa5004

What's the problem? Describe what went wrong.
On the Internet Channel you can type with an on-screen keyboard. If you have Direct3D 11 backend and a non-integer internal resolution, it will seemingly clip through the background.

What steps will reproduce the problem?

To reproduce this bug you'll need:
- Internet Channel WAD or the FIFO log (see link at the bottom of the report)
- Direct3D 11 Backend
- Internal Resolution set to a non-integer value (1.5x, 2.5x, Auto)
Start up the Internet Channel and make the keyboard appear. Luckily, you can do exactly that immediately from the title screen, just press A on the WWW icon to input a web address. Do you see the keyboard?

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Latest Dolphin 4.0-9215 and builds from a few months ago all seem to bee affected. Didn't test further.

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10, Athlon II X2 240, Nvidia GT 240

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Screenshot:
http://i.imgur.com/TJGJfXw.png

Video:
https://mega.nz/#!41oxgQKY!hCraK8itZlLzt_Xlv78SpM3koSWmcmNqajfHPmau8pI

FIFO log:
https://mega.nz/#!d9ZmFY4A!LcvXSFFusWkoZXiQMiQKXuyl9YLD1vS8cGuNyCkXRHM


Related issues

Is duplicate of Emulator - Emulator Issues #8747: Remove 1.5x and 2.5x Internal Resolution OptionsFixed

History

#1 Updated by JMC4789 almost 4 years ago

  • Status changed from New to Duplicate

#2 Updated by JMC4789 almost 4 years ago

Also available in: Atom PDF