Project

General

Profile

Emulator Issues #9488

Plugging in / unplugging laptop while playing SSBB results in brief slowdown

Added by ryanebola16 almost 4 years ago. Updated about 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros. Brawl

Game ID? (right click the game in the game list, properties, info tab)

RSBE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

c55273506f0814362f1f6defc354263b (edited ISO, works fine on both Dolphin and real Wii)

What's the problem? Describe what went wrong.

Plugging in / unplugging laptop while playing SSBB results in brief slowdown (60 fps -> 1-20 fps for a few seconds). I tested with a few other games and couldn't reproduce the problem. I do know that in older versions of Dolphin (~3.5) this problem was much worse.

What steps will reproduce the problem?

Plug in / unplug laptop while playing SSBB

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-9215

What are your PC specifications? (CPU, GPU, Operating System, more)

Win 10 Pro x64
Intel Core i7-4702MQ CPU @2.20GHz
GeForce GT 750M
GeForce Game Ready Driver 364.72

History

#1 Updated by kostamarino almost 4 years ago

  • Status changed from New to Questionable

I am pretty sure this happens due to a power mode switch in your laptop when you unplug it. Anyways i highly doubt this has something to do with dolphin, but rather your laptop doing what is supposed to do when unplugged, switching power modes.

#2 Updated by ryanebola16 almost 4 years ago

I tested this on both "HP Recommended" and "High Performance" power options. In "High Performance" the only difference between "On battery" and "Plugged in" is "Minimum processor state" (5% battery, 100% plugged in).

The problem occurred with both power settings. Are there power settings in other locations that I can adjust to see if they cause changes? Nothing power related could be found in my NIVIDIA Control Panel.

#3 Updated by JMC4789 almost 4 years ago

It's likely your laptop. The way things shift even beyond the power plan could cause a brief/permanent slowdown.

#4 Updated by ryanebola16 almost 4 years ago

Even if that's true this issue is still a problem that can annoy Dolphin users. Since the problem was worse in previous versions of Dolphin something may be able to be done within Dolphin to improve this situation. I'm open to testing ideas if anyone else can think of something. The issue is very easy to reproduce on my laptop.

#5 Updated by JMC4789 almost 4 years ago

My laptop does the same thing in every game.

#6 Updated by Fog almost 4 years ago

  • Status changed from Questionable to Invalid

There's just nothing that we can do about it.

#7 Updated by ryanebola16 about 3 years ago

Is there a reason nothing can be done about this issue? I still think it's valid even if it's really difficult to fix. It's also pretty annoying.

#8 Updated by Helios about 3 years ago

Dolphin doesn't need to fix anything. The flaw is not with Dolphin.

It's your laptop juggling CPU and GPU clocks as you plug / unplug.

Also available in: Atom PDF