Project

General

Profile

Emulator Issues #9510

Add support for Metal for Dolphin on OSX

Added by SoaringHawk820 over 4 years ago. Updated 16 days ago.

Status:
Won't fix
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Since Apple seems to not be updated their support for OpenGL and instead is now mainly using Metal, a OpenGL and OpenCL hybrid, wouldn't it make sense to allow Dolphin to support it so that games will be able to use the updates that have been made to the emulator that require a newer version of OpenGL? This isn't necessarily something for Dolphin 5.0, but a good feature to consider so that games will function properly.

History

#1 Updated by Helios over 4 years ago

  • Priority changed from Normal to Low
  • Operating system OS X added
  • Operating system deleted (N/A)

This probably isn't going to happen unless some gung ho OS X dev pops up out of the wood works and is really excited about writing a brand new backend for Dolphin.

But, hey. The request is here. I guess. ;)

#2 Updated by Fog over 4 years ago

  • Issue type changed from Bug to Feature request

#3 Updated by JMC4789 over 4 years ago

Honestly I think it'd be pointless to hold on as a feature request. Either someone will want to implement it or someone won't. DX12 happened because someone just went out and did it.

#4 Updated by Helios over 4 years ago

Yeah. But if people start whining about it we can just say it's a documented, requested feature and then continue on with our day.

#5 Updated by JMC4789 over 4 years ago

Oh yeah, I think this issue should stay. I just don't know if it'll change anything. Unless we're planning on rejecting the support, this should stay open.

#6 Updated by SoaringHawk820 almost 4 years ago

With Vulkan support on the way to help optimize games running on Dolphin on Windows, it would make snese to afterwards look into finally optimizing support for OS X users by creating a backend for Metal since OS X users have been plagued by bugs that were fixed for Windows but not OS X due to lack of Open GL support. It feels like OS X is lagging behind Windows users tremendously because of it and I think it would be a good thing to look into after the Vulkan backend is fully functional in Dolphin

#7 Updated by Helios almost 4 years ago

Nobody is going to argue that OS X is kind of screwed by bad performance and bugs, but the issue is nobody cares enough to write (and maintain! RIP D3D12) a Metal backend.

This is simply the nature of unpaid open source. People write the features they care about.

Nobody has forgotten about this issue. It gets brought up every now and then.

#8 Updated by alexchandel about 3 years ago

With the development of Ubershaders, and given the lack of efficient OpenGL drivers is the primary reason Ubershaders don't work on macOS, a Metal backend is looking a lot more attractive.

#9 Updated by Helios over 2 years ago

  • Status changed from New to Fix pending

#10 Updated by 8times9 over 1 year ago

That PR was closed but now we have MoltenVK?

I guess this could be left open as a request for a native Metal backend.

#11 Updated by JMC4789 16 days ago

  • Status changed from Fix pending to Won't fix

Stenzek has abandoned making a Metal Backend. We're using MoltenVK for now, but if someone were to write a Metal Backend up to standards, then it would probably be accepted. Until then I'm closing this issue.

Also available in: Atom PDF