Project

General

Profile

Actions

Emulator Issues #9592

closed

Wii Remote extensions are not detected properly with MotionPlus and Emulated Bluetooth

Added by NarryG over 6 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Wii Sports Resort
The Legend of Zelda: Skyward Sword

Game ID? (right click the game in the game list, properties, info tab)

RZTE01
SOUE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]
60df6a9ab9bda687d88f3b39524d527d

What's the problem? Describe what went wrong.

Games do not detect the presence of a Wii MotionPlus unless an accessory is attached to the Wiimote Plus before the Wiimote is connected. This is happening on a WiiMote Plus (RVL-CNT-01-TR)

What steps will reproduce the problem?

Launch the game.
Load up a sport.
The Motionplus will not be detected by the game

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-9442

What are your PC specifications? (CPU, GPU, Operating System, more)

i7-2600k
GTX 780
32GB ram
Windows 10

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

To start this off, I'm having close to the exact OPPOSITE issue of #9106. This was the only issue I could find with a similar problem. In both cases the Motionplus wasn't being detected but in that issue it'd be detected if they detached the accessory whereas for me it'll only initially detect it if I attach an accessory.

As I stated, I found a workaround that involves plugging an accessory into the Wiimote to get the game to detect the motionplus.
In the case of Wii Sports Resort, these are the workarounds that WORK are:

  • I plug an accessory into my Wii Remote Plus before the game is started and leave it connected until the game detects the presence of the Motionplus (in the case of Wii Sports Resort, it's the sport selection screen [as long as you've played through the intro that happens the very first time you launch the game].). Once the MotionPlus has been detected by the game, I can remove the accessory.
  • I disconnect the Wii Remote Plus while the game is actively searching for the MotionPlus (as in on the player select screen) and re-connect it with an accessory plugged in (again, once the game has detected it I can remove the accessory)

NOTE: With this second workaround, the accessory doesn't HAVE to be plugged in the moment the Wiimote reconnects. As long as it's plugged in before the little "dling" noise is made, it'll then detect the MotionPlus. With both of these methods, once the presence of the Motionplus has been detected, I can remove the accessory. Also, before I do one of these workarounds the game doesn't detect the hotplugging of the nunchuck (which issue #9106 was experiencing) but in my case it wont show up whereas in that case it wouldn't disconnect.

These are the only two methods I've found to make it work. Oddly enough, the little "dling" noise after connecting is played properly from both the controller and the game if I have the accessory connected before it plays, but if I don't have the accessory connected then the controller's speaker only outputs a small amount of static instead of the full sound effect. I can record a video of this if someone wants it, as it seems odd that when it's not detecting the MotionPlus it's also not properly playing the speaker data, whereas when it is detecting the motionplus (as I have the accessory plugged in) the speaker sounds fine.

Here's a GIF demonstrating the issue alongside workaround 2. I can't attach it as it's too large so I'm linking it from my Dropbox
https://dl.dropboxusercontent.com/u/42169829/dolphin_example.gif

As you can see, once it's reconnected the game goes from Wiimote with Nunchuck > Wiimote with Motionplus > Wiimote with MotionPlus and Nunchuck

Two alternatives I tried that DON'T work (and may help diagnose where the issue lies)

  • I plug an accessory into my Wii Remote Plus before the game is started and leave it connected through the menu. I disconnect it before I go to a screen that detects the presence of the MotionPlus. The MotionPlus will not be detected.
  • I plug an accessory into my Wii Remote Plus while on a screen that detects the MotionPlus.

NOTE: Interestingly enough, if I go to a minigame that requires the nunchuck (e.g. archery) it wont detect the presence of a hotplugged nunchuck unless I do one of the earlier workarounds. After I've done one of those earlier workarounds, I can hotplug the nunchuck and the game will detect if it's there or not without me having to reconnect.

Now here's where it gets extra weird. There's a similar but different variation of this issue with Skyward Sword.
If I launch Skyward Sword before any game has detected the presence of the Motionplus with just the Wiimote paired, it'll yell at me to attach both the motionplus and the nunchuck. On the other hand, if I've previously done the workaround to get Wii Sports Resort to detect the Motionplus within the active Dolphin session, Skyward Sword will detect it right away even if there's no accessory connected to it. Unlike Wii Sports Resort which requires me to do one of those workarounds every single time I launch the game to get it to detect the MotionPlus, Skyward Sword only seems to need it detected once per active Dolphin session.

Just to be 100% clear, I'm using a RVL-CNT-01-TR so there's no external MotionPlus and whenever I say "wiimote" I'm referring to the Wiimote Plus and when I say "detect the MotionPlus" I'm not trying to say detecting the presence of an external one, I'm saying detect the one in the controller.


Related issues

Has duplicate Emulator - Emulator Issues #9106: Nunchuk Seems To Confuses Wii Sports Resort If MotionPlus Is Connected (even when using a Wii RemotePlus)Duplicate

Actions
Has duplicate Emulator - Emulator Issues #10880: Motion Plus IssueDuplicate

Actions
Is duplicate of Emulator - Emulator Issues #7444: Wii Remote extensions are not detected properly with MotionPlus and Emulated BluetoothWorking as intendedBilliard26

Actions
Actions #1

Updated by JMC4789 over 6 years ago

  • Status changed from New to Accepted

This only happens in Wiisports Resort AFAIK. But yes, it happens, can confirm.

Actions #2

Updated by Helios over 6 years ago

Can also confirm this happens in Skyward Sword.

Whenever I boot the game I always have to do some prodding with cycling the Wiimote and replugging the nunchuk to get past the "Connect your motion+" screen

Actions #3

Updated by JMC4789 over 6 years ago

Huh, that game usually works for me. Good to know it can happen in any game.

Actions #4

Updated by palxex over 5 years ago

Confirms on OSX sierra. Thanks issue reporter figured the method, I cannot find a solution everywhere else.

Actions #5

Updated by leoetlino almost 5 years ago

  • Has duplicate Emulator Issues #9106: Nunchuk Seems To Confuses Wii Sports Resort If MotionPlus Is Connected (even when using a Wii RemotePlus) added
Actions #6

Updated by leoetlino almost 5 years ago

Actions #7

Updated by leoetlino almost 5 years ago

  • Subject changed from Games don't detect Motionplus unless I plug an accessory into Wiimote (RVL-CNT-01-TR) to Wii Remote extensions are not detected properly with MotionPlus
Actions #8

Updated by leoetlino almost 5 years ago

  • Subject changed from Wii Remote extensions are not detected properly with MotionPlus to Wii Remote extensions are not detected properly with MotionPlus and Emulated Bluetooth

This issue doesn't affect Bluetooth passthrough.

Actions #9

Updated by Billiard26 about 4 years ago

  • Is duplicate of Emulator Issues #7444: Wii Remote extensions are not detected properly with MotionPlus and Emulated Bluetooth added
Actions #10

Updated by Billiard26 about 4 years ago

  • Status changed from Accepted to Duplicate
Actions

Also available in: Atom PDF