Project

General

Profile

Emulator Issues #9598

Paper Mario: The Thousand-Year Door partner issue with D3D12

Added by PapaJoe almost 4 years ago. Updated about 2 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand-Year Door (USA)

Game ID? (right click the game in the game list, properties, info tab)

G8ME01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

db9a997a617ee03bbc32336d6945ec02

What's the problem? Describe what went wrong.

All (or at least Goombella and Koops) partners textures will be glitched.
Koops
Goombella

What steps will reproduce the problem?

By selecting D3D12 as a backend.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0-9450

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i3-6100 CPU @ 3.70GHz
NVIDIA GeForce GTX 950
Windows 10 Home 64-bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

None minus images provided up above.

G8ME01-2.png (1.13 MB) G8ME01-2.png Goombella PapaJoe, 06/15/2016 11:23 PM
G8ME01-1.png (1.13 MB) G8ME01-1.png Koops PapaJoe, 06/15/2016 11:24 PM
5452
5453

History

#1 Updated by Fog almost 4 years ago

D3D12 is still considered experimental, so this may get fixed in the future when it is more stable.

#2 Updated by mathieui almost 4 years ago

  • Subject changed from Paper Mario: The Thousand-Year Door partner issue to Paper Mario: The Thousand-Year Door partner issue with D3D12
  • Operating system Windows added
  • Operating system deleted (N/A)

#3 Updated by PapaJoe almost 4 years ago

Well it turns out it still happens with D3D11 also

#4 Updated by PapaJoe almost 4 years ago

But it goes away when you disable Scaled EFB Copy.

#5 Updated by JMC4789 almost 4 years ago

Does it happen on OpenGL?

#6 Updated by JMC4789 almost 4 years ago

Also, are you using the widescreen hack too?

#7 Updated by PapaJoe almost 4 years ago

I don't know what you mean with widescreen hack but it still happens with OpenGL

#8 Updated by Helios about 2 years ago

  • Status changed from New to Won't fix

I killed D3D12 dead. Closing.

Also available in: Atom PDF