Project

General

Profile

Actions

Emulator Issues #9633

closed

Feature Request: Use Wii Classic Controller (Pro) as Gamecube Controller

Added by Codemasta over 7 years ago. Updated over 7 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

At the moment there is no way to play gamecube games with a classic controller pro without external programs.

Actions #1

Updated by mathieui over 7 years ago

And it is likely to stay that way.

Actions #2

Updated by Helios over 7 years ago

  • Status changed from New to Won't fix

On Linux, this works out of the box AFAIK once you connect with bluetooth, on Windows/OS X, it's not really up to Dolphin to directly handle various controllers. The Wii U GC adapter was a special case because there were definitely benefits (Like more accurate input). If the controller exposes dinput or xinput, it'll work. If it doesn't, it's up to the user to make it so IMO.

Actions

Also available in: Atom PDF