Project

General

Profile

Actions

Emulator Issues #9698

closed

Gecko OS crashes Dolphin when started with D3D11 and fullscreen

Added by ThePeoplesKnee over 7 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-76
Fixed in:

Description

Game Name?

GeckoOS 1.9.3.1

Game ID? (right click the game in the game list, properties, info tab)

N/A

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

N/A

What's the problem? Describe what went wrong.

Dolphin crashes when Gecko OS is launched if D3D11 is the selected video backend and fullscreen is enabled from the start. If Dolphin is started in windowed mode, it works fine, and Alt-Enter can be used to put it into fullscreen without any issues. D3D12 and OpenGL are not affected by this issue and work fine whether fullscreen is on from the start or not.

What steps will reproduce the problem?

1) Open Dolphin, any pre-existing settings config should work
2) Go to the graphics settings and set the backend to D3D11
3) Enable fullscreen from the graphics menu
4) Start GeckoOS
5) Watch as Dolphin hangs

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

After bisecting the issue, any build past 5.0-76 causes the issue. 5.0-72 and under can be started in fullscreen on D3D11 without any issues.

What are your PC specifications? (CPU, GPU, Operating System, more)

OS: Windows 10
CPU: i7 4700MQ
GPU GT 755M
RAM: 8GB

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Was tested with two configs, one that was active for over a year and one that was completely clean with default settings all around. The crash happened to both installations of Dolphin.


Related issues 1 (0 open1 closed)

Is duplicate of Emulator - Emulator Issues #9723: Dolphin hanging forever when launching any Wii games in full screen + DX11Fixed

Actions
Actions #1

Updated by phire over 7 years ago

  • Regression changed from No to Yes
  • Regression start set to 5.0-76

Note: elf version of GeckoOS.

And the ProjectM elf launcher is affected too.

Actions #2

Updated by JosJuice over 7 years ago

  • Status changed from New to Duplicate

This doesn't only affect Gecko OS. Marking as duplicate of an issue report that describes that it happens for all Wii games.

Actions #3

Updated by JosJuice over 7 years ago

  • Is duplicate of Emulator Issues #9723: Dolphin hanging forever when launching any Wii games in full screen + DX11 added
Actions

Also available in: Atom PDF