Project

General

Profile

Emulator Issues #9706

Eternal Darkness broken after PR#3716

Added by Nucleoprotein over 2 years ago. Updated about 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Eternal Darkness

Game ID? (right click the game in the game list, properties, info tab)

GEDE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

118e4cbf529719528f15d065130511e2

What's the problem? Describe what went wrong.

Eternal Darkness freezes on "Edgar Allan Poe" quote, broken in "CoreTiming: Drop ProcessFifoWaitEvents." PR#3716 marge.
Sound continues, but all rendering is freezed, even OSD information from GPU backed are freezed.

What steps will reproduce the problem?

Run game on any build after PR#3716 marge.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Used bisection to find out that first broken revision is 5.0-72, master is broken too.

What are your PC specifications? (CPU, GPU, Operating System, more)

Q6600 (I know is old as hell), R7 360, Windows 10

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

It's freezing on this screen: http://vignette1.wikia.nocookie.net/eternaldarkness/images/8/8c/Eternal_Dark.JPG/revision/latest?cb=20120613023554

History

#1 Updated by Nucleoprotein over 2 years ago

Last full working is 5.0-69, build-bot does not have revs 70,71 to download.

#2 Updated by JMC4789 over 2 years ago

Can you try single core and various other settings and mess with the Emulated CPU Clock and see if something weird is going on.

#3 Updated by Nucleoprotein over 2 years ago

Yep, disabling dual core also fixes problem.

#4 Updated by JMC4789 over 2 years ago

Then it's a bug that the other path is even hit. That's nice to know.

#5 Updated by Nucleoprotein over 2 years ago

So I found a game that is doing something strange :P? I don't know very well Dolphin internals so I do not understand exactly what you mean. This problem looks like rendering thread is hanging ie. desyncs, some race condition ?

#6 Updated by JMC4789 over 2 years ago

It's definitely an interesting bug, but that doesn't mean anything can be done about it. Can you try the Synchronize GPU option in the game properties page? If that works, then we can temporarily enforce that to avoid the hang.

#7 Updated by Nucleoprotein over 2 years ago

Synchronize GPU option does not help, but setting Deterministic dual core to fake-completion helps, but I think this can cause other problems.

#8 Updated by JMC4789 over 2 years ago

If the game doesn't use EFB Copies to RAM or EFB Access to CPU, Deterministic Dualcore should work.

#9 Updated by kolano about 1 year ago

We closed this out too soon. It also effects the "Interactive Multi Game Demo Disc 2002-06" G96E01

#10 Updated by kolano about 1 year ago

Er, didn't close it out but likely should have after the Eternal Darkness INI got updated in 5.0-4788. In anycase the other INI needs an update too.

Also available in: Atom PDF