Project

General

Profile

Actions

Emulator Issues #9730

closed

[Netplay] Official GCN Controller adapter random down-left inputs on control and C stick

Added by kaigz almost 8 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros Melee

Game ID? (right click the game in the game list, properties, info tab)

N/A

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

N/A

What's the problem? Describe what went wrong.

Both the control stick and the C stick will randomly input down and left without me even touching the controller. Happens about every 10 seconds. I've seen posts about this problem elsewhere but there hasn't been a response with a solution.

What steps will reproduce the problem?

It happens as soon as I start up the game.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0
4.0.2
4.0-7840

4.0-7840 seemed to fix the issue, but instead replaced it with multiple missed and lagged inputs so that the game was even more unplayable than it was before.

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10
AMD FX-8320 3.50 GHz Eight-Core AM3+ CPU 8MB L2 Cache & Turbo Core Technology
16GB (8GBx2) DDR3/2133MHz Dual Channel Memory (ADATA XPG V3)
GIGABYTE 970-Gaming SLI AMD 970 ATX w/ USB 3.1, Intel GbLAN, 1x M.2, 2 PCIe x16, 2 PCIe x1, 2 PCI
AMD Radeon RX 470 4GB GDDR5 Video Card (Single Card)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]


Related issues 1 (0 open1 closed)

Is duplicate of Emulator - Emulator Issues #9486: Random inputs with official WiiU Adaptor on gamesInvalid

Actions
Actions #1

Updated by Myougi almost 8 years ago

Melee Game ID - GALE01
MD5 Hash - 0e63d4223b01d9aba596259dc155a174

Myougi here. I'm also experiencing the same issue in 5.0-321, and 4.0-9414.
At random intervals, the controller (both the official Nintendo Wii U adapter and the 4-port Mayflash adapter that are natively supported) will input random down left inputs on both sticks. In a game like Super Smash Bros. Melee, this will cause characters to down-smash randomly.

From what I've gathered from my tests, though short, is that this only seems to happen on netplay. I have no experienced this problem using the build for local emulation.

It is worth noting that when on netplay a controller is unplugged from my adapter the inputs default to down left on both sticks, forcing the character in-game to d-smash and immediately crouch.

I'm still looking into this issue myself and talking with Anther/JMC, but as far as I know I haven't found any fixes for this. I'm going to be testing out other adapters soon (2-port mayflash, raphnet GC to USB) and see if the problem occurs there as well.

Actions #2

Updated by MayImilae almost 8 years ago

  • Subject changed from Official GCN Controller adapter random down-left inputs on control and C stick to [Netplay] Official GCN Controller adapter random down-left inputs on control and C stick
  • Status changed from New to Accepted
  • Regression changed from No to Yes

Two thorough reports, marking as accepted. Can anyone pinpoint when the regression occurred?

Actions #3

Updated by JMC4789 almost 8 years ago

I've never had a dropped input in or outside of netplay on my official adapters. I suspect this isn't Dolphin's fault, especially with that new little tidbit.

Considering you're saying it resulted in laggy/dropped inputs, I actually know what's going on. This behavior happens when something else polls the LibUSB devices. Dolphin temporarily loses them.

Most of the cases I've seen is with other drivers behaving badly, such as bluetooth headphones, sound cards, and even a keyboard/mouse once. The solution has been to use different hardware that didn't interfere with libUSB in previous cases.

Now: if this is only happening in netplay, then it's possible that Dolphin is doing something differently in netplay. But narrowing down what it is doing different in netplay may be hard; not sure yet, not too familiar if it's handled differently, and if it is, how so.

Actions #4

Updated by kaigz almost 8 years ago

I'm having the error upon start up of the game. I've only just installed dolphin for the very first time and haven't even looked into setting up Netplay yet, and I still get the random inputs as soon as the game boots.

I friend of mine suggested unplugging my mouse and keyboard when playing, which seemed to correspond with what JMC said above about certain devices interfering with the LibUSB, but that didn't work either.

Actions #6

Updated by E2xD almost 8 years ago

This has been reported by at least 4 different people on SmashLadder. I cannot isolate the cause as it doesn't happened to me, but I can help by sending people to wherever you need them.

Actions #7

Updated by JMC4789 almost 8 years ago

We found out that this is likely a bug in windows. the person who reported it on IRC said that launching zadig once per windows boot seems to mitigate it.

This is also not a regression, it's just that before when the bug was happening, all inputs dropped instead of it holding a direction.

Actions #8

Updated by E2xD almost 8 years ago

Interesting, What do you mean launching zadig once per windows boot?

Actions #9

Updated by JMC4789 almost 8 years ago

The program that installs the WinUSB driver for the adapter. Every time you shut down/restart you have to run zadig once on the computers with this bug.

Actions #10

Updated by JosJuice over 7 years ago

  • Status changed from Accepted to Duplicate
Actions #11

Updated by JosJuice over 7 years ago

Actions #12

Updated by thisproblemisstillhere over 6 years ago

Has anyone figured this out? I'm currently having the problem after I just bought an emulator and I can't play and it's really frustrating.

Actions #13

Updated by Helios over 6 years ago

Bumping issues like this doesn't actually help anything.

The issue is logged.

Actions #14

Updated by JMC4789 over 6 years ago

The only thing I can recommend is disabling other programs that could interfere, particularly certain audio drivers like to take control of LibUSB devices.

Actions #15

Updated by zomglazrzpewpew about 5 years ago

I run two quite large monitors but theyre both considered shitty for netplay. Ive found that running zadig and reinstalling WUP-028 drivers upon boot and shutting off one monitor solves it for me. Also ive found that running chrome in the background causes the same problem although its much less frequent. FM 5.9 runs fine like this but ive since just bought a GC and Trinitron setup and put it next to my pc and run whatever them fuck i want on my pc while i play lol. Yes my battle station looks fugly.

Actions

Also available in: Atom PDF