Project

General

Profile

Emulator Issues #975

Graphics issues in game

Added by ekshenman over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Maybe I repeat some issues but...

<<Paper Mario 2: The Thousand Year Door>> have OpenGL issues:

  1. If Mario do something action for example go to pipe I have unnecessary (not deleted) 3d object:

http://heroesworld.narod.ru/unnecessary_3d_object1.jpg

But 3D objects of Mario and Ally fine animate:

http://heroesworld.narod.ru/unnecessary_3d_object2.jpg
http://heroesworld.narod.ru/unnecessary_3d_object3.jpg

  1. Some objects have big size:

http://heroesworld.narod.ru/unnormal_3dobject.jpg
http://heroesworld.narod.ru/unnormal_3dobject2.jpg

This object in real:

http://heroesworld.narod.ru/normal_3d_object.jpg

  1. Some objects haven't textures:

http://heroesworld.narod.ru/unnormal_texture.jpg

This objects in real:

http://heroesworld.narod.ru/normal_texture.jpg

About last: if you see at unnormal_texture.jpg at the top game have some
pixels. I think this is textures but they incorrectly showing.
There is some other bugs:

http://heroesworld.narod.ru/unnecessary_3d_object3.jpg

<<Super Paper Mario>>

This game have similary bugs but have one other: when you buy anything in
shop game stoped but not freeze. I think this happend because something are
not initialized after buying.

What version of the product are you using? On what operating system?
Dolphin r3263 Dual Core Mode, Windows XP SP3, AMD Athlon(tm) 64 X2 Dual
Core Processor 4600+, 2Gb RAM, GeForce 6150SE nForce 430


Related issues

Is duplicate of Emulator - Emulator Issues #360: Bounding Box registers are not working correctlyFixed

History

#1 Updated by sl1nk3.s over 10 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF