Project

General

Profile

Emulator Issues #9778

Resident Evil 2/3 Audio Issues

Added by JMC4789 almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Supposedly, the game is overwriting the audio data is being DMAed with zeros, before it gets DMAed out, and proper emulation of the L2 cache would fix this. However this doesn't seem to add up, the game gets fixed when you move the time the DMA completion interrupt arrives. Not when you move the actual copy (we always do the copy instantly).

This issue needs to be solved before the next release.


Related issues

Has duplicate Emulator - Emulator Issues #9833: resident evil 2 (pal) music skippingDuplicate

Is duplicate of Emulator - Emulator Issues #9840: Resident Evil 2, Resident Evil 3: Nemesis Audio IssuesAccepted

History

#1 Updated by JosJuice almost 4 years ago

This started happening after a hack was removed. Details: https://github.com/dolphin-emu/dolphin/pull/3771

JMC, please include details on how to reproduce the issue and how to notice if the issue is happening.

#2 Updated by JosJuice almost 4 years ago

#3 Updated by JosJuice almost 4 years ago

  • Status changed from New to Duplicate

#4 Updated by JosJuice almost 4 years ago

Also available in: Atom PDF