Project

General

Profile

Emulator Issues #9800

[Loading Screen Freeze in DKCR]

Added by jarsh almost 4 years ago. Updated almost 4 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Donkey Kong Country Returns]

Game ID? (right click the game in the game list, properties, info tab)

[SF8E01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[6ff36b6b6b8a42064e73847993c43e4b]

What's the problem? Describe what went wrong.

[Upon loading the world map, the game will freeze as the camera zooms past the clouds. Seems to happen whether I start a new game or load an existing one.]

What steps will reproduce the problem?

[Merely starting a new game or loading an existing game reproduces the problem.]

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[I've used the stable 5.0 release as well as 5.0-649 and 5.0-639. I've not been able to play beyond the loading screen issue with any version since 5.0.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[CPU: Intel Core i5 4570 @ 3.20GHz
GPU: 4095MB NVIDIA GeForce GTX 1070 (Gigabyte)
OS: Windows 10
RAM: 8.00GB Single-Channel DDR3 @ 931MHz (10-10-10-30)]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[I've not tried to play the PAL or NTSC-J versions, only the NTSC-U version.]

History

#1 Updated by JosJuice almost 4 years ago

Do you mean that 5.0 and all versions afterwards don't work, or only that versions after 5.0 don't work? If it's the latter, please test if it works when all Gecko codes are turned off.

#2 Updated by jarsh almost 4 years ago

Sorry, I worded it poorly. I meant the former, 5.0 and all versions afterwards don't work. I haven't tried anything pre-5.0 yet.

Also, I haven't been using any Gecko codes. I just tried again to be sure, with Gecko codes of course, and the same thing happened.

#3 Updated by mstreurman almost 4 years ago

Works perfectly on my computer, I am unable to reproduce this, doesn't matter which revision I use

#4 Updated by JMC4789 almost 4 years ago

Have you been using savestates? There used to be an issue with the bonus stages + savestates.

#5 Updated by JMC4789 almost 4 years ago

If no one can reproduce this then I'm going to have to mark it as invalid. Maybe we need a new closed issue thing "unreproduceable" or something because it doesn't feel right marking this as invalid. I feel like we'll hit this eventually...

#6 Updated by seapancake almost 4 years ago

I wasn't able to replicate either on 5.0-1053. How do you know it's a 5.0 issue if you haven't tested previous builds?

#7 Updated by jarsh almost 4 years ago

I did a clean install of 5.0, meaning I deleted everything Dolphin-related, and now the issue seems to have disappeared. Huh, since nobody can replicate the issue, I guess it was perhaps user error. Quite strange, but I appreciate everyone's help!

#8 Updated by JosJuice almost 4 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF